lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-07-2012, 12:45 PM   #1
Not Yet Wild
 
Join Date: Oct 2012
Posts: 43
Default installed D & D 5020 and lost speed

I have an 08 CC precedent IQ. Just installed the D & D 5020 motor. I actually talked with Jeff and he said that with all stock and just the motor install I would see about 40% more torque and my speed of 17mph would stay the same. Hard to tell if Torque is better until I go hunting next week so I cant say if that is better but my speed has gone from a clocked, consistent 17mph on flat ground to about 5 or 6 top speed. Can anyone give any advice on what happend and what I should do to fix this? My cart is all stock except for a 6 inch jakes lift and 22" tires. Motor went on easier than I thought and except for the sore right shoulder killing me from holding it up all is good
angriffnole is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-08-2012, 12:32 AM   #2
Not Yet Wild
 
Join Date: Oct 2012
Posts: 43
Default Re: installed D & D 5020 and lost speed

motor i installed is a 170-502-0002, sorry bout that. Anybody with any suggestions maybe?
angriffnole is offline   Reply With Quote
Unread 12-08-2012, 01:25 AM   #3
Gone Wild
 
lmswest's Avatar
 
Join Date: Jul 2012
Posts: 366
Default Re: installed D & D 5020 and lost speed

Sounds like something might be wired incorrectly
lmswest is offline   Reply With Quote
Unread 12-08-2012, 09:34 AM   #4
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: installed D & D 5020 and lost speed

Call them but maybe the controller needs programming.
Speedchaser is offline   Reply With Quote
Unread 12-08-2012, 09:50 AM   #5
Not Yet Wild
 
Join Date: Oct 2012
Posts: 43
Default Re: installed D & D 5020 and lost speed

Guys I triple checked the wiring, it is hooked up right. I thought the same thing. Everything on my cart is stock. Can you program a stock controller?
angriffnole is offline   Reply With Quote
Unread 12-08-2012, 10:43 AM   #6
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: installed D & D 5020 and lost speed

Sorry for some reason I though you had an alltrax. The new motor should disable regen braking and the speed sensor on the new motor should disable the speed limit set by the controller so probably no reason to program stock controller.
Speedchaser is offline   Reply With Quote
Unread 12-08-2012, 12:22 PM   #7
Not Yet Wild
 
Join Date: Oct 2012
Posts: 43
Default Re: installed D & D 5020 and lost speed

speedchaser, do you think the stock controller is what slowed the cart from 17mph to 6.
angriffnole is offline   Reply With Quote
Unread 12-08-2012, 12:33 PM   #8
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: installed D & D 5020 and lost speed

I cannot answer that for sure, but I would think that motor needs at least a DCX500 controller for that motor because to get that kind of torque it needs a lot of amps.

That said, I have seen some high torque motors out there that only go about 6-10 miles per hour because they are rated at high HP at low RPM's. Not sure what the specs of your motor are though. For high torque speed will be sacrificed and visa versa for speed.

I think they rated top speed on your motor at 14mph and they are thinking you will get 17 cuz of your taller tires, however it is possible the controller is not feeding enough amps for the motor to reach its high rpm rating which would result in lower speed.

I looked at their spec sheet and am a little skeptical, on the 9 peak HP motor they say you must upgrade controller, but on yours they said you could use stock, just makes no sense to me.
Speedchaser is offline   Reply With Quote
Unread 12-08-2012, 12:47 PM   #9
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: installed D & D 5020 and lost speed

One more thing, please tell us your top speed in reverse cuz if you are going faster you prbably switched some wires at the motor.
Speedchaser is offline   Reply With Quote
Unread 12-08-2012, 02:28 PM   #10
Not Yet Wild
 
Join Date: Oct 2012
Posts: 43
Default Re: installed D & D 5020 and lost speed

Thanks speedchaser for the info, at work now but I will call and get my wife to check and then try to post back in an hour or two.
angriffnole is offline   Reply With Quote
Reply

Tags
motor 170-502-0002
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Lost of speed and climbing ability Electric Club Car
Cart lost speed and won't climb Electric Club Car
08 Precedent lost speed Electric Club Car
ezgo speed lost Electric EZGO
Lost low speed on my 98 electric cart Electric Club Car


All times are GMT -5. The time now is 06:09 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.