lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-23-2012, 02:37 PM   #1
Not Yet Wild
Club Car
 
Join Date: Sep 2012
Location: Mid-Michigan
Posts: 7
Default Installed 6" Jakes Lift - Now no Brakes!

I recently installed a 6" Jakes lift on my 2009 Precedent and now it does not stop when pressing the brake pedal and the parking brake doesnt want to engauge/lock. It feels like there is not tension.

I double checked in the installation instructions and have followed everything to a "t". I never took my hubs off, so nothing inside them would have been adjusted......

What could be causing this to happen? Is this common when installing this kit?
smuznu is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
What kind of offset is my EZGO RXV w/Jakes 6" Lift Kit and 2" spacer rear and 1" back Lifted Golf Carts
Jakes lift and wheels installed - FINALLY Electric Club Car
DS Jakes 3" and 22x11-10 installed Electric Club Car
My Jakes 6" Lift is now installed Gas Yamaha
Looking for pics of a G1 with Jakes lift installed Gas Yamaha


All times are GMT -5. The time now is 02:26 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.