lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-17-2013, 04:03 PM   #1
Not Yet Wild
 
Join Date: Jan 2013
Posts: 6
Default Bad Boy Buggie - Navitas No Movement

Hello I am New to the site and have found you guys seem to have the most knowledge when it comes to these Bad Boy Buggies. Sorry if this is the wrong section I did my best.

Ive got a BB-AMS4 (at least that's all I can find for a name stamp), its the 48v Dual Motor 4wd with the Navitas Controller (green)

Originally run and drove fine. Headlights didn't work and I ended up just removing them from the circuit and wiring them to the cigarette lighter using the existing switch. They work fine now.

I also Fixed the Metal bracket on the bottom of the cart that holds the brake cable (manual brakes weren't working)

once finished I turned the key on and went to back it out of the garage.. No Movement. After Several attempts to figure out what was going on I put everything back to stock. No luck.

-Turn key to on Volt Meter Reads Full. Forward Solenoid Engages (or reverse depending on what the switch is set too)

-If Auto Brakes are ON when the pedal is depressed you hear the Solenoid Engage and then Disengage when released. You ALSO hear the Drive motor whine just like it always did and moves every so slightly. When Auto Brakes are OFF there is no Clicking of any kind when the pedal is depressed.

I am an ASE and State Certified Automotive Electrical Tech and usually nothing gets by me but this one has me gone for a loop. Any Helpful insights or help in general would be great. Thanks Ray
RPerry435 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-18-2013, 10:08 PM   #2
Not Yet Wild
 
Join Date: Jan 2013
Posts: 6
Default

Well it was worth the shot. Thanks

Sent using my Galaxy SIII on Tapatalk 2
RPerry435 is offline   Reply With Quote
Unread 01-20-2013, 11:31 AM   #3
Not Yet Wild
 
Join Date: Oct 2012
Location: Hernando
Posts: 54
Default Re: Bad Boy Buggie - Navitas No Movement

When you were removing the wires and rewiring your lights I am assuming you had the control panel out of the dash. Could you have possibly bumped the wires loose on the auto brake switch?
Melonbuster is offline   Reply With Quote
Unread 01-21-2013, 08:15 AM   #4
Not Yet Wild
 
Join Date: Jan 2013
Posts: 6
Default

Yeah I can see all wires are connected. All the switches work. I actually did the work pretty much at the headlights just running a 12v power source for the headlights off the cigarette lighter. It's weird everything worked and Went to pull it out.. no movement.

Sent using my Galaxy SIII on Tapatalk 2
RPerry435 is offline   Reply With Quote
Unread 01-24-2013, 03:57 PM   #5
Not Yet Wild
 
Join Date: Jan 2013
Posts: 6
Default Re: Bad Boy Buggie - Navitas No Movement

Okay, Looks like I might have figured out the problem.

The throttle position sensor is supposed to have between 0-4v depending on position of your pedal.

this one is resting at 13.5v and varying down to 10.3v. clearly this isn't right.

did some research found a Recall on the Throttle assembly. Im contacting BBB for a replacement.
RPerry435 is offline   Reply With Quote
Unread 01-24-2013, 08:29 PM   #6
Not Yet Wild
 
Join Date: Oct 2012
Location: Hernando
Posts: 54
Default Re: Bad Boy Buggie - Navitas No Movement

Awesome
Melonbuster is offline   Reply With Quote
Unread 01-25-2013, 07:33 PM   #7
Not Yet Wild
 
Join Date: Jan 2013
Posts: 6
Default

Yeah I know big whoopty but it's a forum for info... Hope it helps someone out some day

Sent using my Galaxy SIII on Tapatalk 2
RPerry435 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Navitas TSE 1000 wiring connections Electric EZGO
Inproper movement? Electric EZGO
new batteries, no movement Electric Club Car
NAVITAS TSE1000 Controller -Exposed Extreme DC!
G9 clutch movement... is it right? Gas Yamaha


All times are GMT -5. The time now is 01:01 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.