lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-18-2013, 08:32 PM   #1
Not Yet Wild
 
Join Date: Jan 2013
Posts: 2
Default Club car acceleration issues

Hoping to find some help...... My grandparents have a club car that was purchased about a year ago from a golf course, electric. I believe it's about 4 or 5 years old but I'm not positive. There is now an issue with the throttle. When you push the pedal slowly the solenoid clicks and one wheel begins to spin. As you push it farther the solenoid clicks again and the wheel stops. It does this in both forward and reverse while the rear wheels are off the ground. When the wheels are on the ground it does the same thing but instead of moving slowly the cart will not move at all with the weight on it, it bucks a little like its trying but won't move. Is there anything I can do to test particular parts or has someone had the same issue and knows where to point me? Seems like a fairly simple system with few complicated parts. Thanks!
Shadowkart42x is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-18-2013, 10:43 PM   #2
haveacupofshutthe****up
 
Stevec3201's Avatar
Club Car
 
Join Date: Jun 2011
Location: Viera, FL
Posts: 739
Default Re: Club car acceleration issues

Quote:
Originally Posted by Shadowkart42x View Post
Hoping to find some help...... My grandparents have a club car that was purchased about a year ago from a golf course, electric. I believe it's about 4 or 5 years old but I'm not positive. There is now an issue with the throttle. When you push the pedal slowly the solenoid clicks and one wheel begins to spin. As you push it farther the solenoid clicks again and the wheel stops. It does this in both forward and reverse while the rear wheels are off the ground. When the wheels are on the ground it does the same thing but instead of moving slowly the cart will not move at all with the weight on it, it bucks a little like its trying but won't move. Is there anything I can do to test particular parts or has someone had the same issue and knows where to point me? Seems like a fairly simple system with few complicated parts. Thanks!
Welcome,

I guess you checked the batteries, right? It sounds like dead batteries to me. After you verify the batteries have ~50 volts (don't know the model of the cart), we can go from there. Let us know some more info..
Stevec3201 is offline   Reply With Quote
Unread 01-19-2013, 07:21 AM   #3
Not Yet Wild
 
Join Date: Jan 2013
Posts: 2
Default Re: Club car acceleration issues

The batteries are full and fully charged. I also disconnected them from each other and charged them individually with a regular charger. Batteries were my first thought too because the battery light does flash occasionally when I unplug the club car charger and other random times but they seem fine.
Shadowkart42x is offline   Reply With Quote
Unread 01-19-2013, 07:51 AM   #4
haveacupofshutthe****up
 
Stevec3201's Avatar
Club Car
 
Join Date: Jun 2011
Location: Viera, FL
Posts: 739
Default Re: Club car acceleration issues

Quote:
Originally Posted by Shadowkart42x View Post
The batteries are full and fully charged. I also disconnected them from each other and charged them individually with a regular charger. Batteries were my first thought too because the battery light does flash occasionally when I unplug the club car charger and other random times but they seem fine.
If the cart is about 4-5 years old, how old are the batteries? The batteries could be showing a full charge, but not pass a load test. You need to load test the batteries and, trouble-shoot from there. Perhaps someone else can chime in with some ideas??
Stevec3201 is offline   Reply With Quote
Unread 01-20-2013, 04:37 PM   #5
Not Yet Wild
Club Car
 
Join Date: Jan 2013
Location: Central FLA
Posts: 1
Default Re: Club car acceleration issues

Had the same problem last week, 2009 Precedent with 09 batteries. Load tested and had two weak batteries..... Replaced 12V with 8V conversion.... all good now.
jdealfl is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1989 club car no acceleration Electric Club Car
1996 Club Car DS rough acceleration Electric Club Car
'83 club car acceleration problem Electric Club Car
1998 club car DS acceleration problems Electric Club Car
94 electric Club Car acceleration problems Electric Club Car


All times are GMT -5. The time now is 09:03 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.