lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-20-2013, 04:02 PM   #1
Gone Wild
 
1970buick's Avatar
 
Join Date: Jul 2012
Location: maryland
Posts: 749
Default precedent dead in the garage

Last weekend I drove the cart and all was well. I accidentally left the key in the ON position and in run mode all week. I could not get the cart to move and the reverse buzzer would not buzz. I checked the ignition with my voltmeter and no power. I checked the batteries and they were all at or around 15 volts. What would I check next? I am frustrated. I also replaced the cables while I was at it today and cleaned the corrosion of the posts.
1970buick is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-20-2013, 04:50 PM   #2
Gone Wild
 
gsf35099's Avatar
Club Car
 
Join Date: Jun 2008
Location: Texas Hill Country
Posts: 390
Default Re: precedent dead in the garage

What is the voltage across the pack?
gsf35099 is offline   Reply With Quote
Unread 01-20-2013, 06:35 PM   #3
Gone Wild
 
1970buick's Avatar
 
Join Date: Jul 2012
Location: maryland
Posts: 749
Default Re: precedent dead in the garage

Voltage is close to 60
1970buick is offline   Reply With Quote
Unread 01-20-2013, 07:00 PM   #4
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: precedent dead in the garage

Quote:
Originally Posted by 1970buick View Post
Voltage is close to 60

. . . huh?
Stevegrmich is offline   Reply With Quote
Unread 01-20-2013, 07:12 PM   #5
Gone Wild
 
gsf35099's Avatar
Club Car
 
Join Date: Jun 2008
Location: Texas Hill Country
Posts: 390
Default Re: precedent dead in the garage

Quote:
Originally Posted by Stevegrmich View Post
. . . huh?
Yeah, my thoughts.

1970buick,
We need some more info to try and help you. ( At least I know I do).
What year of cart?
Is it 48V?
4 12v batt's or 6 8v batt's?

That 60volts sounds really high across the battery pack. I normally see somewhere around 51-53 volts on my 6 - 8volts.
gsf35099 is offline   Reply With Quote
Unread 01-21-2013, 03:57 PM   #6
Gone Wild
 
1970buick's Avatar
 
Join Date: Jul 2012
Location: maryland
Posts: 749
Default Re: precedent dead in the garage

HI, 2008.5 precedent w/ 4 12 volt batteries. It is 52 volts right now, my volt meter was reading to high (chinese crap). Is there a fuse somewhere I could check?
1970buick is offline   Reply With Quote
Unread 01-21-2013, 05:26 PM   #7
Philippians 4:13
 
ArmyVetSgtAdkins's Avatar
Club Car
 
Join Date: Sep 2012
Location: Ohio
Posts: 440
Default Re: precedent dead in the garage

Do you have a schematic of the wiring? I would double check all my cables and make sure that the small red wire is also connected to the + side of your first battery I believe but I'm sure TDawg will see this and help you out if not send him a PM he will take care of you
ArmyVetSgtAdkins is offline   Reply With Quote
Unread 01-21-2013, 05:36 PM   #8
Gone Wild
 
1970buick's Avatar
 
Join Date: Jul 2012
Location: maryland
Posts: 749
Default Re: precedent dead in the garage

thanks! I am going to try and reset the obc tonight and see if that does anything
1970buick is offline   Reply With Quote
Unread 01-23-2013, 08:09 PM   #9
Gone Wild
 
1970buick's Avatar
 
Join Date: Jul 2012
Location: maryland
Posts: 749
Default Re: precedent dead in the garage

I tried the OBC resetting procedure and still nothing...no buzzer. I hooked up the charger and it is charging fine. What would I check next? Solenoid? I think I would still have reverse buzzer and power at the ignition with a bad solenoid...
1970buick is offline   Reply With Quote
Unread 01-23-2013, 10:39 PM   #10
Not Yet Wild
Club Car
 
Join Date: Jan 2013
Location: Naples fl
Posts: 10
Default Re: precedent dead in the garage

Have you just tried the cart in reverse? Sometimes those precedents switches will stick in forward or reverse, and not trying to be a dick but make sure u didn't accidentally hit the run switch back into tow mode... I've do e this many times while working on them an just forgot to put it back into run!
After Hours is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
06 Club Car IQ Precedent 48 volt dead in driveway Electric Club Car
2005 club car precedent dead Electric Club Car
05 Precedent - Dead - Charger won't come on Electric Club Car
Dead cart, possible dead Solenoid Electric Club Car


All times are GMT -5. The time now is 11:01 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.