lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-31-2013, 12:26 AM   #1
Not Yet Wild
 
Join Date: Jan 2013
Posts: 2
Default Motor arked cart won't run? 2007 club car precendent 48 v

I'm new to this whole golf cart thing so please bare with me. I just bought a used 2007 Club Car Precendent 48V. I just finished a lift kit on it. I thought I would try to get a little more speed out of the cart by adding one of the divide by 2 kits. I had the back cover off so I could see the motor and just my luck my pair of pillars fell and hit the two top posts on the motor. Causing it to ark and spark. The pillars only touched the two posts for a second. So before I went any further I tried the cart out to see if it would move. No movement. The solenoid is clicking but that is it. I know now to put the cart in tow mode to do any work on it. But what did I screw up? The controller? The motor? Anything else? I hope this is a cheap fix but I doubt it is going to be. Any help would be greatly appreciated!!! Thanks
cqmachinery is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-31-2013, 01:18 AM   #2
Not Yet Wild
 
Hornsta's Avatar
Yamaha
 
Join Date: Dec 2012
Location: Torquay Australia
Posts: 69
Default Re: Motor arked cart won't run? 2007 club car precendent 48 v

Do you have a fuse on the battery post or controller connection? I have one on my positive post, I put it there so it's nice and easy to see. You should have a main fuse somewhere on your 07 precedent. If not check with a multimeter from the battery until you find where your not getting power.
Hornsta is offline   Reply With Quote
Unread 01-31-2013, 07:12 AM   #3
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Motor arked cart won't run? 2007 club car precendent 48 v

. . . sounds like you may have taken your controller out of commission by shorting the motor . . . you would not be the first one to do this . . . you will need to test both the motor and controller, but I think the controller is the "weakest link" when this happens . . .
Stevegrmich is offline   Reply With Quote
Unread 01-31-2013, 09:32 AM   #4
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 2,682
Default Re: Motor arked cart won't run? 2007 club car precendent 48 v

Next time disconnect the batteries before working on anything! You probably killed the controller.
Volt_Ampere is offline   Reply With Quote
Unread 01-31-2013, 10:19 AM   #5
Not Yet Wild
 
Join Date: Jan 2013
Posts: 2
Default Re: Motor arked cart won't run? 2007 club car precendent 48 v

I figured it was probably the controller. How do I go about testing the controller before I order a new one?
cqmachinery is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2007 ezgo motor upgrade Big Block Talk!
2007 PDS motor fried Electric EZGO
Club Car Precendent jake lift and wheel question! Electric Club Car
2007 precendent charger help Electric Club Car
Motor for 2007 EZ GO Gas EZGO


All times are GMT -5. The time now is 01:47 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.