lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-01-2013, 09:30 AM   #1
Not Yet Wild
 
Join Date: Feb 2013
Posts: 2
Default Headlights and taillights not working

Good Morning,
I have a 2002 DS48 and this is my first post looking for help with my headlights. They have been working fine however a few days ago they went off while driving. I was not concerned considering they went back on within a few minutes. Problem now is that they have gone off again and now willl not go back on. Here is what I have tried to test but I am not familiar with testing a 48 volt system.

I took a simple test light and hooked the gator clip to what I believe is the last battery in serous ground terminal and then touch the pointed end to positive and checked my test light to make sure it is working. Then I touched the point of the tester to the red lead at the front headlight and have power at the light. While keeping my light on this red wire I turned of the headlight switch and my test light went of as expected. Turned headlight switch on and test light turned back on. It appears the headlight switch is working and the there is power at the headlight from the red wire. Heres where things are strange.....

I then took the point of the tester and checked the black with also at the head light running with the red wire and the tester also light lit up. I verified I was on the negative terminal ground on the battery and checked the black again, and again the test light-lit.

The final strange thing that happened was I touched the point of the tester to the metal housing of my roof top light which is tide into the headlights and the test light lit. This to me was strange and it appeared as though I had my test light on the positive terminal and not negative so I checked it again. I was surely clipping the clip from the tester on negative yet still was seeing getting a power from other areas I thought should not show power.

Can anyone help my diagnose what I am doing wrong with the tester and where I might find what I believe is a loose ground?

Thank you in advance.
G
sunpacceo is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-01-2013, 10:27 AM   #2
Not Yet Wild
Club Car
 
Join Date: Nov 2012
Location: Jennings, LA
Posts: 27
Default Re: Headlights and taillights not working

Did you check the inline fuse for the lights? Mine is under the seat coming from the battery.
tigerfan9984 is offline   Reply With Quote
Unread 02-01-2013, 11:39 AM   #3
Not Yet Wild
 
Join Date: Feb 2013
Posts: 2
Default Re: Headlights and taillights not working

Yes, Thank you. I now my post is long but I had mentioned that I have power to the lights. Do the lights work like a typical 12 volt system where on lead is hot and the other is a ground?
sunpacceo is offline   Reply With Quote
Unread 02-01-2013, 11:55 AM   #4
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Headlights and taillights not working

. . . sure you have power to the headlight and not continuity? Some test probes show continuity and not necessarily power . . . best to check for power with a volt/ohm meter . . .
Stevegrmich is offline   Reply With Quote
Unread 02-01-2013, 08:36 PM   #5
Not Yet Wild
 
Join Date: Oct 2012
Location: Hernando
Posts: 54
Default Re: Headlights and taillights not working

The strange thing to me is that your 12volt test light bulb didn't burn out with 48volts hooked to it. Might indicate that you have a voltage reducer/converter on your cart that you are unaware of. If so you will need to troubleshoot differently.
Melonbuster is offline   Reply With Quote
Unread 02-01-2013, 09:33 PM   #6
Not Yet Wild
Club Car
 
Join Date: Nov 2012
Location: Jennings, LA
Posts: 27
Default Re: Headlights and taillights not working

Quote:
Originally Posted by sunpacceo View Post
Yes, Thank you. I now my post is long but I had mentioned that I have power to the lights. Do the lights work like a typical 12 volt system where on lead is hot and the other is a ground?
You have 12 volts on the wires connecting to the lights? I would be surprised if you do, since both the headlights and taillights are out. I'm far from being an electrician but my guess would be that there had to be something that was loose and eventually lost connection....That would explain them going off, then coming back on, not to mention the fact that you were driving when they went off for good. A short should have caused the fuse to blow, so that shouldn't be your problem, if the fuse is okay. I know I'm not helping much but you don't seem to be getting much help from others, so I'm trying to help as much as I can. I would check your connections at the wiring harness in the dash and the connection at the battery. Since the headlights and taillights are both out, I don't think you problem is at the lights, themselves.
tigerfan9984 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Headlights not working Electric Club Car
Headlights,taillights and Brake lights Oh MY! Electric Club Car
96 ezgo headlights not working Electric EZGO
TXT Headlights/Taillights Kit Golf Carts and Parts
Headlights aren't working Electric Club Car


All times are GMT -5. The time now is 10:10 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.