lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-13-2014, 07:26 PM   #11
Gone Wild
 
CartTrader's Avatar
Club Car
 
Join Date: Aug 2008
Location: Ohio-In Summer, Central Florida-In winter
Posts: 883
Default Re: Speed magnet GE motor

Quote:
Originally Posted by brivy1900 View Post
How did you get it out? Any videos anywhere with a tutorial? I noticed mine has a tiny chip at the edge and not sure if that would ruin it. Im wondering if I just replace the sensor if it will work with a magnet having a tiny chip. I can post a pic, but not sure how through my mobile app.
What year CC do you have? You talking chip on the magnet or a computer type chip on the edge of the opening? I found it easier to take the wheel well plastic out to get more room. Spray wd-40 or equivilent around magnet and wait 1/2 hour before trying to remove magnet it helps.

CartTrader
CartTrader is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-13-2014, 08:06 PM   #12
Not Yet Wild
 
Join Date: May 2011
Posts: 23
Default Re: Speed magnet GE motor

Quote:
Originally Posted by CartTrader View Post
What year CC do you have? You talking chip on the magnet or a computer type chip on the edge of the opening? I found it easier to take the wheel well plastic out to get more room. Spray wd-40 or equivilent around magnet and wait 1/2 hour before trying to remove magnet it helps.

CartTrader
Its a 2003 from the 27th week, 2004 protocol Precedent. The chip im referring to is like its broken. you


Here is a link for a pic.. https://www.dropbox.com/s/yaj9ipscpd...612_140256.jpg
brivy1900 is offline   Reply With Quote
Unread 06-13-2014, 08:33 PM   #13
Gone Wild
 
CartTrader's Avatar
Club Car
 
Join Date: Aug 2008
Location: Ohio-In Summer, Central Florida-In winter
Posts: 883
Default Re: Speed magnet GE motor

Ok magnet is chipped. Yes it will work just fine with that chip. I take it that is the original magnet. My PQ motor had 2/3s of the magnet missing or ground off...I don't recommend doing that though. . Again I found that a paint can opener worked great to take the magnet off. Just work all the way around the magnet a little at a time and it will come off if you are going to put the modified magnet on it. Look where the original magnet is and tap the new one down to the same position. I used the back side of a socket and tapped that with a hammer to get it into place. When I took my magnet off, the plastic magnet ring came off the metal ring for some reason as shown in pic.

CartTrader
Attached Images
File Type: jpg 100_1430.jpg (94.0 KB, 0 views)
CartTrader is offline   Reply With Quote
Unread 06-13-2014, 08:47 PM   #14
Not Yet Wild
 
Join Date: May 2011
Posts: 23
Default Re: Speed magnet GE motor

Quote:
Originally Posted by CartTrader View Post
Ok magnet is chipped. Yes it will work just fine with that chip. I take it that is the original magnet. My PQ motor had 2/3s of the magnet missing or ground off...I don't recommend doing that though. . Again I found that a paint can opener worked great to take the magnet off. Just work all the way around the magnet a little at a time and it will come off if you are going to put the modified magnet on it. Look where the original magnet is and tap the new one down to the same position. I used the back side of a socket and tapped that with a hammer to get it into place. When I took my magnet off, the plastic magnet ring came off the metal ring for some reason as shown in pic.

CartTrader
Thanks SO MUCH for your help!!
brivy1900 is offline   Reply With Quote
Unread 06-13-2014, 10:29 PM   #15
Gone Wild
 
CartTrader's Avatar
Club Car
 
Join Date: Aug 2008
Location: Ohio-In Summer, Central Florida-In winter
Posts: 883
Default Re: Speed magnet GE motor

:



CartTrader
CartTrader is offline   Reply With Quote
Unread 07-22-2014, 09:31 PM   #16
Not Yet Wild
Club Car
 
Join Date: Jun 2014
Location: Cayce, SC
Posts: 18
Default Re: Speed magnet GE motor

Is there a particular direction the magnet needs to go in? Is there an inside and outside to the magnet or does it not matter which side is pointing out? I installed mine today and went from 19 mph on a flat surface to 8 mph! Help!
Bcrabbit3 is offline   Reply With Quote
Unread 07-23-2014, 10:54 AM   #17
Gone Wild
 
teecro's Avatar
Club Car
 
Join Date: Jun 2014
Location: Sunset Bay, TN
Posts: 2,122
Default Re: Speed magnet GE motor

Quote:
Originally Posted by Bcrabbit3 View Post
Is there a particular direction the magnet needs to go in? Is there an inside and outside to the magnet or does it not matter which side is pointing out? I installed mine today and went from 19 mph on a flat surface to 8 mph! Help!
What year is your cart and what is the the first part of your serial number? If your cart is an Excel the speed magnet does not work. Sounds to me like your cart is in go home limp mode.
teecro is offline   Reply With Quote
Unread 07-23-2014, 03:11 PM   #18
Not Yet Wild
Club Car
 
Join Date: Jun 2014
Location: Cayce, SC
Posts: 18
Default Re: Speed magnet GE motor

I seemed to have messed up my speed sensor when I was getting it out. I just replaced it and tested. Back up to 22 mph on a flat surface!
Bcrabbit3 is offline   Reply With Quote
Unread 03-23-2015, 11:18 AM   #19
Not Yet Wild
 
Join Date: Dec 2014
Posts: 2
Default Re: Speed magnet GE motor

So, does the sensor just pop out as well? What holds it on? I saw where someone took the 2 screws out and found out they should not have........
RedRambler is offline   Reply With Quote
Unread 03-23-2015, 01:33 PM   #20
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 6,788
Default Re: Speed magnet GE motor

Quote:
Originally Posted by RedRambler View Post
So, does the sensor just pop out as well? What holds it on? I saw where someone took the 2 screws out and found out they should not have........
The sensor snaps out. Don't take those two screws out next to the sensor unless you want to go fishing for the bearing retainer. The magnet can be removed without taking the motor apart in most cases. It just takes some persuading.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Speed Magnet Accidental Find for DS IQ Regen with GE Motor Electric Club Car
GE high speed motor magnet ??? Electric Club Car
Speed Magnet Electric Club Car
Another speed magnet ? Electric EZGO
Speed Magnet Accidental find for DS IQ Regen with GE Motor Extreme DC!


All times are GMT -5. The time now is 08:07 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.