lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-09-2013, 07:05 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jun 2011
Posts: 33
Default GE magnet

Just I stalled a speed magnet on 05 precedent with ge motor. I don't really see a big difference. Can you put this in wrong or backwards. The directions didnt really state either way. Any suggestions????
zachsclub is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-09-2013, 07:35 PM   #2
Gone Wild
 
CartTrader's Avatar
Club Car
 
Join Date: Aug 2008
Location: Ohio-In Summer, Central Florida-In winter
Posts: 887
Default Re: GE magnet

What speed code were you on before you installed the magnet? I just installed one on my 2002 DS GE motor about an hour ago. I was told I had speed code 4, but it would max out at 17.4 MPH even going down hill. Now on flat ground I hit just at 19MPH, but on a slight downhill I got a max so far of 24.5MPH. BIG difference on top end. Torque stayed the same. I am going to try it tomorrow with windshield down and a fresh charge on batteries. Did you have any problems installing the magnet?

CartTrader
CartTrader is offline   Reply With Quote
Unread 02-09-2013, 07:39 PM   #3
Not Yet Wild
Club Car
 
Join Date: Jun 2011
Posts: 33
Default Re: GE magnet

It's on 3. Ran it before I swapped the magnet on GPS. Hit 14 mph. After the magnet I hit 16. Not sure I put it own right. Taking the other one off was a nightmare but got it done
zachsclub is offline   Reply With Quote
Unread 02-09-2013, 07:52 PM   #4
Gone Wild
 
CartTrader's Avatar
Club Car
 
Join Date: Aug 2008
Location: Ohio-In Summer, Central Florida-In winter
Posts: 887
Default Re: GE magnet

On my magnet the was a metal lip on one side and was flush on the other. When I got the other magnet off I noticed the lip was toward the motor. So that is how I put my magnet back on. Have you tried going on a downhill grade to see how fast you can go? How old are your batteries? I also put on 4 gauge wires. My 6 gauge were getting really warm just on the speed code 4 setting, so that will make a difference. Personally I don`t think you have it on wrong, because if you did the speed sensor wouldn't work. And neither would the cart. You can only go as fast as the motor can turn with the amount of current it can get.

CartTrader
CartTrader is offline   Reply With Quote
Unread 02-09-2013, 07:57 PM   #5
Not Yet Wild
Club Car
 
Join Date: Jun 2011
Posts: 33
Default Re: GE magnet

I agree. I guess after years of drag racing and actually feeling changes I was expecting big changes. It has woke up the cart for sure but not gonna say it is wicked quick. I was going down a gradual slope and hit 19 mph. Gues that's not bad for a buggy
zachsclub is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Speed magnet Electric Club Car
What Motor do I Have?? I want to install magnet Electric Club Car
Speed Magnet Electric Club Car
Another speed magnet ? Electric EZGO
High Speed Magnet Electric Club Car


All times are GMT -5. The time now is 10:21 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.