lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars

Post New Thread  Reply
Thread Tools Display Modes
Unread 02-14-2013, 10:55 PM   #1
Not Yet Wild
Join Date: Feb 2013
Location: Iowa
Posts: 3
Default 1997 Club Car Regen no forward or reverse wont run

I am working on a 1997 Club Car DS with the Regen system in it. It has the rocker type forward and reverse, the wiper ( pie shaped box) style accelerator and two solenoids.

The car came in and was stone dead with complaints of charging problems. It ran slow, started to chug and died, the owner could not get it to move or take a charge. I attempted to charge the car and it would not charge. I checked the batteries and found one bad one. I replaced it , made sure all of the wiring was correct and it still would not charge. I tried a different charger and it would not charge. I unhooked the batteries , pressed down the accelerator and held it with the car in reverse ,no reverse buzzer sounded, hooked the wiring back up, plugged in the charger and nothing. Unplugged it from the wall and plugged it back in an it fired right up. No idea why but it started to charge after that and now works fine with any charger.

I now have great battery voltage. I discharged the car and it went 77 minutes (on a fairly old set of batteries). I charged it back up and have great voltage for the entire pack. But the car will not move. When I turn the key on the main solenoid clicks with the key, not with the pedal as it should. I replaced the microswitch (accelerator limit switch) that has the green and blue wires going to it and still no change, it clicks with the key. I have no reverse buzzer when in reverse. I have 51.3 volts at one side of the solenoid, 50.3 at the other large terminal when the key is off as it should be. With the key on I have 51.3 at both large terminals.

What causes this issue? The club car manual says that if the solenoid clicks with the key then the micro switch is at fault but I replaced that and still have the problem. I am leaning towards the controller but I do not know much about the Club Cars accept that everyone says this model is a pain to work on and diagnose problems on. Any help would be greatly appreciated.
schroederfarley is offline   Reply With Quote
Alt Today

Golf car forum Sponsored Links

This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
Unread 02-15-2013, 12:17 PM   #2
Not Yet Wild
Club Car
Join Date: Jan 2013
Location: Georgia
Posts: 6
Default Re: 1997 Club Car Regen no forward or reverse wont run

I just went throgh the same thing but that does not mean what fixed mine will fix yours. Jump the solenoid behind the passenger seat (2 big lugs) and see if it will go. If it does, use your volt meter to check the two small lugs with peddle pushed down - you should get 36 - 48 vdc, If you do you have a bad solenoid. Have you ohm'ed out all the wires? Hope that helps
Ted K is offline   Reply With Quote
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car

Thread Tools
Display Modes

Similar Threads
Thread Forum
1997 TXT forward reverse question Electric EZGO
G-9 wont shift forward or reverse Big Block Talk!
1997 regen club car upgrades Electric Club Car
Reverse alarm sounds in Forward, wont go forward or reverse Electric Club Car
Help, G1 Wont go forward. Only Reverse. Gas Yamaha

All times are GMT -5. The time now is 05:02 PM.

Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.