lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-10-2013, 08:46 AM   #1
Not Yet Wild
 
Amberjax's Avatar
Club Car
 
Join Date: Apr 2009
Location: Suffolk, Va.
Posts: 31
Default Weird problem

All of a sudden I'm having a problem with my cart where it seems when I switch the run/tow switch to run, turn on the key and try to move the cart, I have no power. The battery meter is reading fully charged, but the reverse buzzer won't come on and the cart won't move. After what seems to be 15-30 seconds, and I keep trying, the reverse buzzer will eventually move and everything is fine for the rest of the day.
Before I go digging into it, anyone ever heard of this before? I believe the key switch is working because I have the battery meter light wired to the on side of the switch.
Thanks in advance!
Amberjax is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-10-2013, 07:46 PM   #2
Gone Wild
 
CartTrader's Avatar
Club Car
 
Join Date: Aug 2008
Location: Ohio-In Summer, Central Florida-In winter
Posts: 887
Default Re: Weird problem

Yes mine does that sometime when I turn the switch on and hit the pedal. I think the controller which is a computer just hasn't booted up, for lack of a better term. But it is usually just a couple of seconds wait.


CartTrader
CartTrader is offline   Reply With Quote
Unread 03-10-2013, 07:54 PM   #3
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,883
Default Re: Weird problem

Quote:
Originally Posted by CartTrader View Post
Yes mine does that sometime when I turn the switch on and hit the pedal. I think the controller which is a computer just hasn't booted up, for lack of a better term. But it is usually just a couple of seconds wait.


CartTrader
If mine has been sitting for a couple days, it will do what CartTraders does.
I have to tap the pedal then let off then hit it agin before it goes. I think it kind of has to "wake up". It is just a second or two though, never 30 seconds
jakesnake27 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
'04 villager 4-Very weird battery problem Electric Club Car
82' EZ GO gasser with a weird problem Gas EZGO
Starting problem - weird Gas Club Car
new guy. weird no power problem Gas EZGO
Weird Charging problem Electric Club Car


All times are GMT -5. The time now is 03:55 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.