lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-02-2013, 05:18 PM   #1
Not Yet Wild
 
Join Date: Apr 2013
Posts: 2
Question 09 Precedent speed modulates

When driving at ~medium speeds my 48 volt CC will not run smoothly. It modulates or pulses forward then slows, then forward and slows... At full speed it runs smooth. Talked to my local dealer and they said this was sometimes typical of CC and not to worry about it. Is this normal? Is it going to get worse? Anybody else have this problem? Thanks
Pwess is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-02-2013, 05:21 PM   #2
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,883
Default Re: 09 Precedent speed modulates

Quote:
Originally Posted by Pwess View Post
When driving at ~medium speeds my 48 volt CC will not run smoothly. It modulates or pulses forward then slows, then forward and slows... At full speed it runs smooth. Talked to my local dealer and they said this was sometimes typical of CC and not to worry about it. Is this normal? Is it going to get worse? Anybody else have this problem? Thanks
I certainly don't think this is 'typical'.
It sounds like your MCOR may be going out...
jakesnake27 is offline   Reply With Quote
Unread 04-03-2013, 06:03 AM   #3
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 09 Precedent speed modulates

Quote:
Originally Posted by Pwess View Post
When driving at ~medium speeds my 48 volt CC will not run smoothly. It modulates or pulses forward then slows, then forward and slows... At full speed it runs smooth. Talked to my local dealer and they said this was sometimes typical of CC and not to worry about it. Is this normal? Is it going to get worse? Anybody else have this problem? Thanks

. . . loosely translated, "I have no clue what is wrong with it" . . .
Stevegrmich is offline   Reply With Quote
Unread 09-07-2014, 08:05 AM   #4
Not Yet Wild
 
Join Date: Sep 2014
Posts: 1
Default Re: 09 Precedent speed modulates

I have the same problem, only mine also happens at top speed. With a full charge it starts out OK, then shortly it begins slowing down and speeding up intermittently. Sometimes it seems that it is going to stop altogether. Is that similar to what yours is doing?
George Schlink is offline   Reply With Quote
Unread 09-07-2014, 09:29 PM   #5
Gone Wild
Club Car
 
Join Date: Feb 2012
Location: Indio, CA The Desert!
Posts: 1,177
Default Re: 09 Precedent speed modulates

mcor
smokey tennis shoe is offline   Reply With Quote
Unread 09-11-2014, 05:43 AM   #6
Gone Wild
Club Car
 
Join Date: Oct 2008
Location: East Texas
Posts: 318
Default Re: 09 Precedent speed modulates

I've had similar problems on my two Precedents in the past. If it's the potentiometer in the MCOR that is dirty and causing the speed problem, you can work the go pedal up and down a bunch of times either in neutral or with the key off. After doing that, see if the problem still exists. If it goes away, it's the MCOR. You can either replace it or do this little procedure whenever it acts up.
basshawk84 is offline   Reply With Quote
Unread 09-13-2014, 07:56 PM   #7
Not Yet Wild
 
Join Date: Aug 2014
Posts: 1
Default Re: 09 Precedent speed modulates

Having the same issue, but my '99 CC doesn't beep when the motor brake kicks in.

-I replaced the MCOR
-I Replaced the speed sensor
-I tested all the batteries
-I tested all the batteries under load
-I've checked all the terminals

Any help would be appreciated... [8]
WW8BALL is offline   Reply With Quote
Unread 09-13-2014, 08:14 PM   #8
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 09 Precedent speed modulates

It might be what Curtis calls torque bumps. Check the connections on the motor and controller.
jjance is offline   Reply With Quote
Unread 09-13-2014, 10:23 PM   #9
Gone Wild
Club Car
 
Join Date: Feb 2012
Location: Indio, CA The Desert!
Posts: 1,177
Default Re: 09 Precedent speed modulates

also, possible cracked magnet?
smokey tennis shoe is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car
09 club car speed modulates(pulses) Electric Club Car
Precedent speed question Electric Club Car
More speed 04 CC precedent Electric Club Car
how can i speed up my precedent? Electric Club Car


All times are GMT -5. The time now is 02:01 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.