lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-06-2013, 08:07 PM   #1
Not Yet Wild
 
Amberjax's Avatar
Club Car
 
Join Date: Apr 2009
Location: Suffolk, Va.
Posts: 31
Default 05' Precedent dead

Hey Guys,
05' Precedent w/4 new batteries. Went to Myrtle Beach last week and the cart seemed to run fine with the exception of the battery charge meter not coming on sometimes. Chalked that up to a bad connection, but wasn't concerned.
Loaded the cart in the toyhauler last night and when we got home this afternoon it wouldn't move when I tried to pull it out. I have no reverse buzzer, no battery light. Checked the battery voltage and got 49-50 volts.
I have noticed lately that sometimes when I went to use the cart, I would take it off charge and move the switch to "run" and wouldn't get a reverse buzzer and it seemed like a delay and then it would come on and run the rest of the day. Guess it just wasn't broke all the way yet.
Looking for some ideas as to what happened. It's strange that it was fine for the last week on vacation and the second I got home it's dead.
Amberjax is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-07-2013, 06:15 AM   #2
Not Yet Wild
 
Amberjax's Avatar
Club Car
 
Join Date: Apr 2009
Location: Suffolk, Va.
Posts: 31
Default Re: 05' Precedent dead

Went out last night and decided to throw the charger on it just to see if it made a difference. Let it charger for a good while and it usually takes only about and hour to charge since the batteries are new, but after several hrs. the charger was still pegged like it was just plugged in. I unplugged it from the cart and tried the cart again. It started working again. I wonder if the OBC solenoid lockout circuit was activated.
Gonna run all the tests in the book today to see what's happening.
Amberjax is offline   Reply With Quote
Unread 04-07-2013, 11:27 AM   #3
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: 05' Precedent dead

Let it charge you are ruining your bats
Speedchaser is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
precedent dead in the garage Electric Club Car
06 Club Car IQ Precedent 48 volt dead in driveway Electric Club Car
2005 club car precedent dead Electric Club Car
05 Precedent - Dead - Charger won't come on Electric Club Car
Dead cart, possible dead Solenoid Electric Club Car


All times are GMT -5. The time now is 12:07 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.