lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-11-2013, 09:30 PM   #1
Not Yet Wild
 
Join Date: Apr 2013
Posts: 2
Default 92 club car No power and slow

I have a 92 club car. It has 6 batteries that i guess are 6V because there are 3 cells in each battery. The batteries are quite old (9 years old) I tested the batteries and after a full charge i get 8V out of one and 7.5 out of the rest, All together I get 45.3 volts. I replaced the V glide because it cracked but it runs the same with the new one. I admit i know nothing about golf carts so any advice is great. My brother has a 91 same model and his runs very fast (18 -20 mph) with alot of power. I can push it very easy so I dont think the breaks are hanging up. Any advice?
ldutcher is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-11-2013, 09:36 PM   #2
Gone Wild
 
Xact1's Avatar
Club Car
 
Join Date: Jun 2009
Location: Binghamton, NY
Posts: 384
Default Re: 92 club car No power and slow

Something doesn't sound right. A 36V (6) battery system will have around 38-39 volts after a charge and a little time to settle down the batteries. Take a good look at every one of the batteries, ensure that they are 6V.
Xact1 is offline   Reply With Quote
Unread 04-14-2013, 08:03 PM   #3
Not Yet Wild
 
Join Date: Apr 2013
Posts: 2
Default Re: 92 club car No power and slow

They are all 6 volts. After sitting all weekend they now read 37.9V
ldutcher is offline   Reply With Quote
Unread 04-14-2013, 09:45 PM   #4
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,889
Default Re: 92 club car No power and slow

If the batteries are 9 years old, they definitely need replaced! They are probably dropping right out under load...
jakesnake27 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
New batteries - still slow no power Electric Club Car
1982 Club Car very slow no power Electric Club Car
EZGO TX Goes very slow, little power Electric EZGO
89 CC has little power and slow Electric Club Car
Slow! How do I make my club car Gasser go really slow. Gas Club Car


All times are GMT -5. The time now is 07:23 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.