lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-12-2013, 11:53 AM   #1
Not Yet Wild
 
Join Date: Apr 2013
Posts: 1
Default 08 club car charging issues-48v

Ok so I got two club cars. Last year all batteries were replaced with interstates. I topped off the (distilled)water one time, and it wasn't even that low. Lately they go out and can't get a full day out of them.....soo here's what I did so far and know....

Chargers seem to be working fine, a little hot to touch but runs about 6 hrs. Start at 15 for an hour or two then gradually drop to 10 and5 amps as a deep cycle would. They are power drive 3 chargers.

After a full charging cycle I put a hydrometer to each cell, I get clear color water but only 50% life in ever cell. All equal so I think I can rule out bad batteries or even one being bad. Also after a full charge I get around 50v which is normal.

Obviously I cleaned all terminals, sprayed terminal protector and double checked all wires n connections and fuse. So now I'm leaning toward obc, cuz I know they control the charger.

I tried the procedure several times to reset it but I'm not getting the buzzer sound after 30 seconds or even 5 minutes. What could I be doing wrong?

I read on another thread about jumping the yellow fuse out the charger end and going right to neg, plug in charger and see if it kicks on. It did not turn on, which says my obc is ok, but not sure how thorough that test is.



Next test I'm doing as we speak is to manually charge a battery on a regular charger, low amp and see if I get better results with my hydrometer, pretty sure that will just confirm my batteries are good.

Ummm what else? HELP!!!! Any feedback is greatly appreciated.
Jerseyjg81 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-13-2013, 11:31 AM   #2
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: 08 club car charging issues-48v

When did you measure voltage after charge, right after or hours after?
If it was right after charger kicked of bats should be at about 65 volts, and after say 12 hours it should be around 51 volts.

50 vilts is only 80% charge.

Sound like bats are wearing out.
Speedchaser is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car charging issues fuse pops out of charger Electric Club Car
Club Car Charging Issues Electric Club Car
Club Car Charging issues Electric Club Car
93 Club Car Charging Issues Gas Club Car
Club Car Charging issues Electric Club Car


All times are GMT -5. The time now is 06:31 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.