lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-17-2013, 12:42 PM   #31
Not Yet Wild
Club Car
 
Join Date: Oct 2012
Location: Charlton MA
Posts: 65
Default Re: problems

here are a couple photos. THe first picture is a general picture of the setup. The second is the 2 batteries under the drivers side as they could not be clearly seen

THe battery layout is as follows. If i am facing the front of the cart from the rear, starting from the left....both batteries positive terminals toward the center of the cart. middle batteries have both positive terminals to the front, and on the right, they are on the outside.
Attached Images
File Type: jpg Resampled_2013-04-17_12-35-28_885.jpg (229.0 KB, 0 views)
File Type: jpg Resampled_2013-04-17_12-35-40_898.jpg (181.6 KB, 0 views)
2004hdfxsti is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-17-2013, 12:46 PM   #32
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,064
Default Re: problems

Your batteries are connected in series = plus to neg (+ to - ) from one end of the 'pack' to the other. THere are only two battery cables which connect to a battery but DO NOT connect to another battery.

Those are the main positive and negative connections. This is where you will get the full 'pack' reading. see diagrams below and find your cart. (FIG A )

Main + is on the driver's side and main - is on the pass side.
Attached Images
File Type: jpg Battery Layouts.jpg (125.2 KB, 0 views)
scottyb is offline   Reply With Quote
Unread 04-17-2013, 12:53 PM   #33
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,064
Default Re: problems

The batteries are positioned correctly, here are the mains
Attached Images
File Type: jpg Resampled_2013-04-17_12-35-28_885.jpg (384.8 KB, 0 views)
scottyb is offline   Reply With Quote
Unread 04-17-2013, 12:55 PM   #34
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: problems

. . . what is red cable going to negative terminal on left battery in pic #2? Sense lead?
Stevegrmich is offline   Reply With Quote
Unread 04-17-2013, 01:02 PM   #35
Not Yet Wild
Club Car
 
Join Date: Oct 2012
Location: Charlton MA
Posts: 65
Default Re: problems

everything is wired correctly. The red wire is going to the charge plug. I mentioned that above that when i attach it to a positive, it blows the breaker in my house when charger plugged in. Plugged in negative it runs the charger normally, but no reading on the guage of the charger. fuse at charge plug in clear holder is good
2004hdfxsti is offline   Reply With Quote
Unread 04-17-2013, 01:13 PM   #36
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: problems

Quote:
Originally Posted by 2004hdfxsti View Post
everything is wired correctly. The red wire is going to the charge plug. I mentioned that above that when i attach it to a positive, it blows the breaker in my house when charger plugged in. Plugged in negative it runs the charger normally, but no reading on the guage of the charger. fuse at charge plug in clear holder is good
. . . interesting . . . red wire from charger receptacle should be going to main positive terminal . . .
Stevegrmich is offline   Reply With Quote
Unread 04-17-2013, 01:16 PM   #37
Not Yet Wild
Club Car
 
Join Date: Oct 2012
Location: Charlton MA
Posts: 65
Default Re: problems

it should be on the first positive, back battery on the passenger side?
2004hdfxsti is offline   Reply With Quote
Unread 04-17-2013, 01:21 PM   #38
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: problems

Quote:
Originally Posted by 2004hdfxsti View Post
it should be on the first positive, back battery on the passenger side?
. . . correct . . and I am assuming that your main negative terminal's cable passes thru the OBC (On Board Computer). . . correct?
Stevegrmich is offline   Reply With Quote
Unread 04-17-2013, 01:23 PM   #39
Not Yet Wild
Club Car
 
Join Date: Oct 2012
Location: Charlton MA
Posts: 65
Default Re: problems

correct. to the solenoid
2004hdfxsti is offline   Reply With Quote
Unread 04-17-2013, 01:28 PM   #40
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,064
Default Re: problems

somebody could have just grabbed whatever cable they had and put red on negative? but ordinarily red is reserved for + flow to keep things safe. Good pics of the charge receptacle connections possible?
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Txt problems Gas EZGO
95 txt dcs f/r problems Electric EZGO
G9 problems Gas Yamaha
possble battery problems or possible charger problems? Extreme DC!
6 passanger trouble shooting. Controller problems/gas/or brake problems. Electric EZGO


All times are GMT -5. The time now is 05:40 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.