lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-17-2013, 01:29 PM   #41
Not Yet Wild
Club Car
 
Join Date: Oct 2012
Location: Charlton MA
Posts: 65
Default Re: problems

i just put it on the correct battery. Charger will still not start. Should i try it with jumper wire?
2004hdfxsti is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-17-2013, 01:33 PM   #42
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,101
Default Re: problems

Quote:
Originally Posted by 2004hdfxsti View Post
i just put it on the correct battery. Charger will still not start. Should i try it with jumper wire?
I don't trust anything on the cart at this point is there another cart you can try the charger on? Or is there another charger you can try on the cart?

A jumper is a good way to force start the charger but what if the connections to the pack are wrong?
scottyb is online now   Reply With Quote
Unread 04-17-2013, 01:33 PM   #43
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: problems

Quote:
Originally Posted by 2004hdfxsti View Post
i just put it on the correct battery. Charger will still not start. Should i try it with jumper wire?
. . . with this red wire from charger receptacle now on the main positive terminal, there is no other cable from charge receptacle on that same terminal, correct?
Stevegrmich is offline   Reply With Quote
Unread 04-17-2013, 01:33 PM   #44
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: problems

Quote:
Originally Posted by 2004hdfxsti View Post
correct. to the solenoid
You are saying your main negative going through the obc is attached to the solenoid? I am pretty sure the main positive goes to solenoid and negative going through obc to b- on controller.
Speedchaser is offline   Reply With Quote
Unread 04-17-2013, 01:35 PM   #45
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,101
Default Re: problems

Quote:
Originally Posted by Speedchaser View Post
You are saying your main negative going through the obc is attached to the solenoid? I am pretty sure the main positive goes to solenoid and negative going through obc to b- on controller.
Correct
scottyb is online now   Reply With Quote
Unread 04-17-2013, 01:36 PM   #46
Not Yet Wild
Club Car
 
Join Date: Oct 2012
Location: Charlton MA
Posts: 65
Default Re: problems

here is a photo of the rear of the charge plug. When i changed the OBC, I replaced the wires right where they previously were. The cart WILL drive....extreeeeeeemely slow though.
Attached Images
File Type: jpg Resampled_2013-04-17_13-33-05_416.jpg (177.0 KB, 0 views)
2004hdfxsti is offline   Reply With Quote
Unread 04-17-2013, 01:37 PM   #47
Not Yet Wild
Club Car
 
Join Date: Oct 2012
Location: Charlton MA
Posts: 65
Default Re: problems

I am sorry I was mistaken. The main negative is going to the controller. To the middle spot on the controller
2004hdfxsti is offline   Reply With Quote
Unread 04-17-2013, 01:43 PM   #48
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: problems

Where the main positive cable goes to solenoid, check voltage there, that shoul be same as pack voltage. You really need to make sure you are getting proper pack readings before troubleshooting. If you do not know how ask.

But individually you indicated nearly full charge on the bats yet your pack voltage is far less. You need to figure this out before moving forward cuz until you do nothing will work right.
Speedchaser is offline   Reply With Quote
Unread 04-17-2013, 01:43 PM   #49
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: problems

. . . I will back out of this thread and just monitor to see results . . stick with ScottyB to troubleshoot your issue . . too many cooks . . .
Stevegrmich is offline   Reply With Quote
Unread 04-17-2013, 01:52 PM   #50
Not Yet Wild
Club Car
 
Join Date: Oct 2012
Location: Charlton MA
Posts: 65
Default Re: problems

Ok. So I need to get the complete pack voltage correct? Best to check at solenoid or at batteries?
2004hdfxsti is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Txt problems Gas EZGO
95 txt dcs f/r problems Electric EZGO
G9 problems Gas Yamaha
possble battery problems or possible charger problems? Extreme DC!
6 passanger trouble shooting. Controller problems/gas/or brake problems. Electric EZGO


All times are GMT -5. The time now is 05:33 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.