lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-29-2013, 06:27 PM   #1
Not Yet Wild
 
Join Date: Jan 2012
Posts: 2
Default sloooow speed

Hello everyone:
2008 club car ds 48v
my problem started when I left for the golf course, cart ran fine on the return trip cart started out fast and 5 seconds later slowed to around 3 or 4 miles an hour. I read somewhere it could be the dc controller. the batteries are fine
each one measures approximatley 12.6 +-. the battery pack reads 55.3 v while charging and 50.93 when charged. I removed the rod from under the cart that goes from the padel to a black box around 3X5. not sure if the controller or the box is bad, has anyone had this problem? any help would be appreciated.
thanks.
stroaker1
stroaker1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-29-2013, 11:48 PM   #2
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,862
Default Re: sloooow speed

Possibly you're speed sensor went bad. Do a speed sensor test. (sticky above)
jakesnake27 is offline   Reply With Quote
Unread 04-30-2013, 07:16 AM   #3
Not Yet Wild
 
Join Date: Jan 2012
Posts: 2
Default Re: sloooow speed

Thanks for the reply, what is the proccess for checking speed sensor, I replaced the magnet in the end bell to get a little more speed but that was 2 months ago, I took the speed sensor of to check and see if the magnet broke, everything looked ok.
stroaker1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR? Speed Sensor? Controller? Cart Runs at half speed. Advice, please. Electric Club Car
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car
1981 club car slow speed fast speed Electric Club Car
Disassembled, re-assembled, now sloooow Electric EZGO
1985 G1 Runs fine low speed , high speed run for a mile then fall on its face Gas Yamaha


All times are GMT -5. The time now is 10:21 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.