lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-30-2013, 08:54 PM   #1
Not Yet Wild
 
croc1's Avatar
Club Car
 
Join Date: Mar 2009
Posts: 37
Default sparks

ok i made a rookie mistake I didnt switch to tow mode before i worked on electrical.. I have a 2009 precedent. 48 volt. I was hooking up a digital volt meter and when i cut at the same time (another mistake)the red and black wires next to the low voltage light i got sparks... what did I short out and where should I look to find out what i fried!! i am looking for help!!!
croc1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-30-2013, 09:14 PM   #2
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: sparks

Are you saying the cart does not run?
Also, just flipping the run tow switch is not enough you should disconnect the main bat cables prior to working on the cart.

Controllers hate sparks.
Speedchaser is offline   Reply With Quote
Unread 04-30-2013, 09:22 PM   #3
Not Yet Wild
 
croc1's Avatar
Club Car
 
Join Date: Mar 2009
Posts: 37
Default Re: sparks

no it does not run,, no click or reverse buzzer.. no volts to the wires i cut..it was 51 volts. lights still work and I still have 51 volts in my battery pack
croc1 is offline   Reply With Quote
Unread 04-30-2013, 09:44 PM   #4
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: sparks

what two wires did you cut exactly? I believe the reverse buzzer is somewhere around that area as well as the key switch so you may have disabled your key switch or cut the wires to the buzzer? Or was that prewired for the meter? So you did not put in tow and you did not remove the two main bat cables prior to work obviously, that could lead to other problems as well like a blown controller. Are you getting power to the controller with key switch on?
On my 2008 the reverse buzzer will go off even with key switch off.
Speedchaser is offline   Reply With Quote
Unread 04-30-2013, 09:54 PM   #5
Not Yet Wild
 
croc1's Avatar
Club Car
 
Join Date: Mar 2009
Posts: 37
Default Re: sparks

i cut the red wire and the black one with the yellow strip. i left the low battery light and wires alone. I definetly did not touch any of the buzzer wires or key switch wires .. yes my buzzer used to go off with the key on or off now it does nothing
croc1 is offline   Reply With Quote
Unread 05-01-2013, 09:21 AM   #6
Not Yet Wild
 
croc1's Avatar
Club Car
 
Join Date: Mar 2009
Posts: 37
Default Re: sparks

how can i tell if I nuked my controller?
croc1 is offline   Reply With Quote
Unread 05-01-2013, 09:48 AM   #7
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,079
Default Re: sparks

Have you repaired the cut wires to see if it still runs?
scottyb is offline   Reply With Quote
Unread 05-01-2013, 10:03 AM   #8
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 2,684
Default Re: sparks

Look for a blown fuse.
Volt_Ampere is offline   Reply With Quote
Unread 05-01-2013, 10:22 AM   #9
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,057
Default Re: sparks

looking at a 04 diagram there is a fuse to the run/tow switch area.. have you checked that ?
Attached Images
File Type: jpg 2004precedent a.jpg (259.3 KB, 0 views)
crash test dummy is offline   Reply With Quote
Unread 05-01-2013, 08:55 PM   #10
Not Yet Wild
 
croc1's Avatar
Club Car
 
Join Date: Mar 2009
Posts: 37
Default Re: sparks

yes scotty i repaired the wire no change. volt yes i checked the fuse and it is good. thank you for the diagram crash, my wires are identical with exception to the ones i cut / shorted out they are a red one and black one with yellow stripe that were right between the key switch and the low volt light
croc1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
So now i have sparks! Electric EZGO
sparks fly Electric EZGO
Sparks Electric EZGO
Help....I got sparks!!! Electric Club Car
sparks Electric EZGO


All times are GMT -5. The time now is 05:41 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.