lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-02-2013, 03:44 PM   #1
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Charger humming, no amperage display

Next question. I have all new batts in my 96 and when I plug the charger in, I hear it buzz but I get no increase in amperage. If the batteries are charged, shouldnt I get at least a slight increase?

Thanks
Shempferd
shempferd is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-02-2013, 04:05 PM   #2
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,066
Default Re: Charger humming, no amperage display

are you getting voltage through the battery pack ?
crash test dummy is offline   Reply With Quote
Unread 05-03-2013, 05:20 PM   #3
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Re: Charger humming, no amperage display

The cart runs and I do get 48v across #! and #6. Is that what you mean?
shempferd is offline   Reply With Quote
Unread 05-03-2013, 05:46 PM   #4
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,066
Default Re: Charger humming, no amperage display

yes .. amp meter maybe bad
crash test dummy is offline   Reply With Quote
Unread 05-03-2013, 10:09 PM   #5
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Re: Charger humming, no amperage display

I just hooked up the charger and tested voltage with and without it powered. I got the same reading, 47.6v. Should the voltage be higher under charge?
shempferd is offline   Reply With Quote
Unread 05-03-2013, 10:09 PM   #6
Gone Wild
 
Colbyntx's Avatar
Club Car
 
Join Date: Jun 2010
Location: East Texas
Posts: 602
Default Re: Charger humming, no amperage display

If your only reading 48V's across your pack then your new batteries are about dead. That's only a 45% charge which you should NEVER do. They should read more like 51V's fully charged for new batteries. Read the pack voltage before you put it on the charger. Then plug it in and wait a few moments and read them again. If its going up then your charger is charging. If no increase then we need to look at the charger next. If its humming but not charging then your rectifier could be bad.
Colbyntx is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
98 ezgo humming will not engage Electric EZGO
g14 solenoid humming Gas Yamaha
36 volt charger output amperage difference Electric Yamaha
G1 - Something humming at high speed Gas Yamaha
Humming/Clicking Noise in Rear End Electric EZGO


All times are GMT -5. The time now is 12:19 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.