lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-08-2013, 11:26 AM   #1
Not Yet Wild
 
Join Date: Feb 2012
Posts: 20
Default 06 Carryall IQ slow forward

Been reading thru the forums here trying to find a fix to my issue and havent as of yet. I have an 06 IQ Carryall2. I checked batteries, 50vs, checked each one seperately and i have 6.5 volts, load test each battery, test good. I replaced all cables with new ones. Problem is, in reverse i seem fine but when i go forward, i am moving less than half speed. I tested speed sensor and found it was bad, replaced it with a new one. Still have the same issue. I checked MCOR and it tested good but replaced it with a known good one and still same issue. Any help would be a appreciated.
Ackerst is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-08-2013, 11:29 AM   #2
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,861
Default Re: 06 Carryall IQ slow forward

If you have one or more batteries at 6.5 volts, there's your problem.
Check each battery and post results. Also check the date code to see how old they are...
jakesnake27 is offline   Reply With Quote
Unread 05-08-2013, 11:35 AM   #3
Not Yet Wild
 
Join Date: Feb 2012
Posts: 20
Default Re: 06 Carryall IQ slow forward

These are 6 volt batteries, 8 of them, less than a year old
Ackerst is offline   Reply With Quote
Unread 05-08-2013, 01:52 PM   #4
Not Yet Wild
 
Join Date: Feb 2012
Posts: 20
Default Re: 06 Carryall IQ slow forward

Just changed out the speed controller off the same year and model and still have the same issue.
Ackerst is offline   Reply With Quote
Unread 05-08-2013, 01:58 PM   #5
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,861
Default Re: 06 Carryall IQ slow forward

Quote:
Originally Posted by Ackerst View Post
These are 6 volt batteries, 8 of them, less than a year old
Oh wow, ok, so it sounds like your batteries are fine...
The new speed sensor does work, right? Maybe just double check, because it seems like it is in limp mode.
jakesnake27 is offline   Reply With Quote
Unread 05-08-2013, 02:03 PM   #6
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,861
Default Re: 06 Carryall IQ slow forward

Exactly how fast are you going in forward? Like walking speed, creeping speed, etc?
jakesnake27 is offline   Reply With Quote
Unread 05-08-2013, 02:25 PM   #7
Not Yet Wild
 
Join Date: Feb 2012
Posts: 20
Default Re: 06 Carryall IQ slow forward

Walking speed
Ackerst is offline   Reply With Quote
Unread 05-08-2013, 02:28 PM   #8
Gone Wild
 
Join Date: Aug 2011
Posts: 384
Default Re: 06 Carryall IQ slow forward

if you go through your wiring diagram you will probably find someone swapped the orange and blue wires at the controller, this is for the field then rewired the forward reverse switch to match!
greg-g is offline   Reply With Quote
Unread 05-08-2013, 02:29 PM   #9
Not Yet Wild
 
Join Date: Feb 2012
Posts: 20
Default Re: 06 Carryall IQ slow forward

I retested the speed sensor three times, and it is working fine. Yeah i know i seem to be in limp mode but not really sure why. I checked voltage back at the motor and i have 17v going to the motor with the pedal fully depressed. I should have 32v i know, thats why i changed out the speed controller. I have 9 of these buggies here so swapping parts with know good parts isnt an issue other than time. Do you think i could have an issue with the coil? I checked the omhs on that and i have 190 ohms, its what its suppose to have.
Ackerst is offline   Reply With Quote
Unread 05-08-2013, 02:30 PM   #10
Not Yet Wild
 
Join Date: Feb 2012
Posts: 20
Default Re: 06 Carryall IQ slow forward

No one has worked on these other than me and the wires are in the proper place. It was working just fine the other day and then just went into this slow mode.
Ackerst is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
83 CC forward slow Electric Club Car
Carryall 2 will only start in forward gear? Gas Club Car
HELP .... club car carryall 2 to slow Clone Engine Swaps
Slow forward Electric EZGO
94 Carryall 36V wiring problems, no forward Electric Club Car


All times are GMT -5. The time now is 10:46 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.