lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-09-2013, 08:24 AM   #1
Not Yet Wild
Club Car
 
Join Date: Apr 2012
Location: SC
Posts: 2
Default No Acceleration then Big Surge

I press my accelerator, get nothing for a few seconds then a big surge. Any culprit ideas?

I recently had a local shop upgrade my 2008 Precedent with an Alltrax 500, some unknown high speed motor, 4 gauge cables, heavy duty solenoid & new batteries. I believe they also put installed a used MCOR.
SCStevens04 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-09-2013, 09:13 AM   #2
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: No Acceleration then Big Surge

Not sure I have heard it described that way. With that controller I press the pedal down and it did not hit til a third of the way down and then hit hard, is that what your does?
Speedchaser is offline   Reply With Quote
Unread 05-09-2013, 09:33 AM   #3
Not Yet Wild
Club Car
 
Join Date: Apr 2012
Location: SC
Posts: 2
Default Re: No Acceleration then Big Surge

Well, it does that but I can live with it. The big problem is that I stomp on the pedal, it sits there around 3 seconds then takes off.
SCStevens04 is offline   Reply With Quote
Unread 05-10-2013, 06:18 AM   #4
Mr. Helper
 
ForBruce's Avatar
Club Car
 
Join Date: May 2009
Location: NY Catskills & South carolina
Posts: 436
Default Re: No Acceleration then Big Surge

sounds like your MICOR might be defective.... also the "THROTTLE UP RATE" in the controller programming might be set too high...

I have an alltrex dcx500 and when my throttle up was set high i was able to leave rubber. ( had to lower as the wife spilled food she was taking to another campsite)




also check the throttle curve file..as it might be set to "S-curve" --that can delay acceleration




also do you have a "PRE-CHARGE" resistor across the "2-LARGE" terminals of your solonoid
ForBruce is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2 stroke surge Gas EZGO
G16 Surge-Stall-Surge-Stall... FIXED Gas Yamaha
96 EZGO DCS surge, Why Electric EZGO
surge prob Gas Yamaha
surge in cc Electric Club Car


All times are GMT -5. The time now is 02:59 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.