lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-11-2013, 09:26 AM   #11
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,071
Default Re: Lost my speed...

Quote:
Originally Posted by Stevegrmich View Post
. . . think there was a "falling out" of sorts a year or two ago . . .
A falling out and then he was banned from the website.
Not somebody I would recommend you do business with.
scottyb is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-11-2013, 06:12 PM   #12
Gone Wild
 
Grinds6's Avatar
Club Car
 
Join Date: Sep 2011
Location: North Dakota
Posts: 174
Default Re: Lost my speed...

Think I got it narrowed down to the speed sensor, pushed forward with key on and cart in forward and no beeping or slowing down.
Thanks
Grinds6 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
lost on speed controlles Electric Club Car
installed D & D 5020 and lost speed Electric Club Car
08 Precedent lost speed Electric Club Car
ezgo speed lost Electric EZGO


All times are GMT -5. The time now is 02:09 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.