lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-11-2013, 03:08 PM   #1
Getting Wild
Club Car
 
Join Date: Mar 2013
Location: Syracuse, NY
Posts: 107
Default Runs with the key switch off

Well I am 99% done and I just noticed that my cart will run with and without the key. Thoughts??
Shawn8202 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-11-2013, 03:34 PM   #2
Gone Wild
 
Kudaman's Avatar
Club Car
 
Join Date: Mar 2013
Location: Ottawa, ontario, Canada
Posts: 292
Default Re: Runs with the key switch off

Throw away the key! Lol! Gas or electric cart? Did you do some work on it and this is something new?
Kudaman is offline   Reply With Quote
Unread 05-11-2013, 04:19 PM   #3
Getting Wild
Club Car
 
Join Date: Mar 2013
Location: Syracuse, NY
Posts: 107
Default Re: Runs with the key switch off

I converted it from 36 to 48. And yes. This is a new issue. I swear this thing is possessed!!!
Shawn8202 is offline   Reply With Quote
Unread 05-11-2013, 10:31 PM   #4
Gone Wild
 
Kudaman's Avatar
Club Car
 
Join Date: Mar 2013
Location: Ottawa, ontario, Canada
Posts: 292
Default Re: Runs with the key switch off

Did you rewire the cart? You are sure all wires hooked up the same?
Kudaman is offline   Reply With Quote
Unread 05-12-2013, 04:23 PM   #5
Getting Wild
Club Car
 
Join Date: Mar 2013
Location: Syracuse, NY
Posts: 107
Default Re: Runs with the key switch off

Yes. The wires are the same as before I upgraded.


I wonder if the key switch wires are reversed ... or if that even matters.
Shawn8202 is offline   Reply With Quote
Unread 05-12-2013, 08:21 PM   #6
I Refuse To Get Stuck!!!
 
pachanga90's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Hamlin,NY
Posts: 5,384
Default Re: Runs with the key switch off

Maybe the switch is bad,and not disconnecting?Unhook the batteries,Test across the terminals with an Ohm-meter(Voltage and Ohm-tests don't get along well,you will fry the meter).If it has continuity in both on and off,then the switch is bad.Hope this helps.
pachanga90 is offline   Reply With Quote
Unread 05-12-2013, 08:26 PM   #7
Getting Wild
Club Car
 
Join Date: Mar 2013
Location: Syracuse, NY
Posts: 107
Default Re: Runs with the key switch off

I will give that a try !! Thank you for the help.
Shawn8202 is offline   Reply With Quote
Unread 05-13-2013, 06:27 PM   #8
Getting Wild
Club Car
 
Join Date: Mar 2013
Location: Syracuse, NY
Posts: 107
Default Re: Runs with the key switch off

I am going with Pachanga on this one .... even though I have not had a chance to preform the suggest test, I was thinking ...
When I hooked my battery meter up, it had constant power to it. (Red wire to battery + ; Black to Battery Neg and Yellow to key switch). I had it hooked up absolutely correct... I am sure of it.

I am thinking my key Switch is bad. ..... Thoughts ??
Shawn8202 is offline   Reply With Quote
Unread 05-13-2013, 06:28 PM   #9
Getting Wild
Club Car
 
Join Date: Mar 2013
Location: Syracuse, NY
Posts: 107
Default Re: Runs with the key switch off

I am going with Pachanga on this one .... even though I have not had a chance to preform the suggest test, I was thinking ...
When I hooked my battery meter up, it had constant power to it. (Red wire to battery + ; Black to Battery Neg and Yellow to key switch). I had it hooked up absolutely correct... I am sure of it.

I am thinking my key Switch is bad. ..... Thoughts ??
Shawn8202 is offline   Reply With Quote
Unread 05-13-2013, 09:18 PM   #10
Gone Wild
 
Kudaman's Avatar
Club Car
 
Join Date: Mar 2013
Location: Ottawa, ontario, Canada
Posts: 292
Default Re: Runs with the key switch off

Switches are pretty common to replace. Fairly inexpensive, I wouldn't hesitate.
Kudaman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
G1, idles great, runs rough, runs better when warm Gas Yamaha
Runs 10 minutes then shuts off, wait 5 then runs again... Electric EZGO
runs then quits then runs again Electric EZGO
runs good cold runs bad hot? Gas EZGO
Reverse...runs awesome Forward..runs bad Gas EZGO


All times are GMT -5. The time now is 11:27 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.