lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-17-2013, 08:07 PM   #1
Not Yet Wild
Yamaha
 
Join Date: Aug 2010
Location: Crete IL
Posts: 53
Default help with 1979 forward/reverse unit

I'm working without any manual or clue. My experience is mostly with my gas Yamaha....the Club Car never any trouble till now. at the f/r unit I'm getting a full charge reading of 38.4 and then I press the accelerator and it goes down to 1 or 2 volts. I'm not sure were to take the readings,so I took them from all main wires and all the same.On top of the unit is a small 3 plug receptacle. I get the same readings from the bottom 2 on that and nothing on the top one. It just stopped running this morning after about a 100 yards and won't run at all forward or backward. I've had a problem in reverse and I cleaned and tightened the reverse wire and it worked fine but now nothing. Please give me a little guidence....having a birthday party tomorrow and I need this puppy running. Thanks Greg
gregm227 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-18-2013, 12:10 AM   #2
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,035
Default Re: help with 1979 forward/reverse unit

wow where to start ... well if both forward and reverse are not working I'd check the micro switch on the f/r switch , it should click when you move f/r switch (lever) 2nd check the f/r switch it's self to see if it is making contact with wires , 3rd check the solenoids, 4th all wires , 5th micro switches

here is diagram that might help



i don;t think you have the jumper

crash test dummy is offline   Reply With Quote
Unread 05-18-2013, 09:32 AM   #3
Not Yet Wild
Yamaha
 
Join Date: Aug 2010
Location: Crete IL
Posts: 53
Default Re: help with 1979 forward/reverse unit

thanks...i've got that diagram but where is the micro switch on the f/r unit? is that the 3 plug recepacle on top?? i do get readings from 2 of 3 prongs. what is the proper way to test it? sorry for my ignorance but i've never work on electric carts before.
gregm227 is offline   Reply With Quote
Unread 05-18-2013, 10:31 AM   #4
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,035
Default Re: help with 1979 forward/reverse unit

first jack up carts rear so wheels are off ground , key on & brakes off
when f/r switch is engaged you will hear solenoid click ,
micro switch will show voltage to the prongs when switch is not engaged , and none when in "gear" .. if micro switch is bad you will get reading when f/r is activated

here is photo of 83 cc

crash test dummy is offline   Reply With Quote
Unread 05-18-2013, 01:09 PM   #5
Not Yet Wild
Yamaha
 
Join Date: Aug 2010
Location: Crete IL
Posts: 53
Default Re: help with 1979 forward/reverse unit

thanks that helps...mine is red and has 3 prongs. ido get a reading on the bottom 2 none on top but that small green wire goes over to the charger so i don't believe i should get a reading. when i push the accelerator no reading.
gregm227 is offline   Reply With Quote
Unread 05-18-2013, 01:36 PM   #6
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,035
Default Re: help with 1979 forward/reverse unit

when f/r switch is moved to ether forward or reverse do you hear solenoid click ?
not the gas pedal
i see no wire to charger recptical on diagram



the top 2 are the ones to check .. 3rd it shown but not hooked to anything

how about a photo ?
crash test dummy is offline   Reply With Quote
Unread 05-18-2013, 02:23 PM   #7
Not Yet Wild
Yamaha
 
Join Date: Aug 2010
Location: Crete IL
Posts: 53
Default Re: help with 1979 forward/reverse unit

here's some pics...fuzzy...sorry. the green one does go over to the charger input. i get a click when i 1st push accellerator and then nothing. this time after i checked for voltage my readings on batt pack went down from 37.9 at rest to 35.4 and stayed there. like a major drain in 30 seconds. i was also getting sporadic readings from the main wires. votlmeter is accurate with fresh batt. this was the 1st time for this. i'll recheck after party....scratch that, recheck hungover tomorrow....thanks for all your help and advice. keep it coming greg hopefully the pics will transfer. the extra red and black were voltmeter sorry to have them in way.
Attached Images
File Type: jpg farmer lauren and cart wires 006.jpg (130.9 KB, 0 views)
File Type: jpg farmer lauren and cart wires 009.jpg (139.6 KB, 0 views)
File Type: jpg farmer lauren and cart wires 008.jpg (141.9 KB, 0 views)
gregm227 is offline   Reply With Quote
Unread 05-18-2013, 02:34 PM   #8
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,035
Default Re: help with 1979 forward/reverse unit

yea thats a little fuzzy .. wel enjoy the party
crash test dummy is offline   Reply With Quote
Unread 05-19-2013, 12:47 PM   #9
Not Yet Wild
Yamaha
 
Join Date: Aug 2010
Location: Crete IL
Posts: 53
Default Re: help with 1979 forward/reverse unit

ok micro switch has full reading on the 2 prongs and then goes down to 4 when accelerator is pushed so that's what is supposed to do right?? i'm not getting a reading on the main wire for forward on the switch itself...well sporadic readings, every once in a while it will read 38 volts but most of the time it reads 0. all connections look good. should i take it off and clean and retighten??? is there a test for the switch itself? oh and yeah i'm really hungover..........**** those birthday parties. thanks again for your help
gregm227 is offline   Reply With Quote
Unread 05-19-2013, 02:06 PM   #10
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,035
Default Re: help with 1979 forward/reverse unit

yes it would be good idea to clean and inspect f/r switch
Quote:
well sporadic readings, every once in a while it will read 38 volts but most of the time it reads 0
that's not a good sign... could be bad f/r switch .. you should be getting 36v+ when engaged in forward and 18v in reverse (if its connected to battery 4 as diagram shows)
crash test dummy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2006 ezgo forward is reverse and reverse is forward please help Electric EZGO
Reverse alarm sounds in Forward, wont go forward or reverse Electric Club Car
Reverse alarm stuck - motor won't run forward or reverse Electric EZGO
Alarm sounding in forward. No movement in forward or reverse Electric Club Car
Forward Reverse switch melted on forward...have question about replacement part Electric Club Car


All times are GMT -5. The time now is 05:37 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.