lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-21-2013, 08:27 PM   #1
Not Yet Wild
 
Join Date: Apr 2011
Posts: 5
Default Speed Problems

I am having issues with my '04 Electric Precedent. The cart runs fine in reverse and it starts extremely slow and is very slow to accelerate in forward. I have a PQ Bandit motor that has been working great for over a year. I have not had any performance issues until recently.

I have tested my solenoid and it seems to be fine and when jacked up the rear wheels appear to be getting full speed - the problem only occurs when I am trying to drive it.

Only other issue I have had in the past few months is I have had two battery terminals melt down. I assumed a bad connection the first time, but I had been checking my connections constantly since the first one and it did not prevent a second occurance.

I have two 25 amp converters to power my amplifier and lights, but those have been there for a while without issue. Just thought I would provide all the info that might possibly be relevant.

Thanks guys.
smaumau is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-21-2013, 10:42 PM   #2
Not Yet Wild
 
Join Date: Apr 2011
Posts: 5
Default Re: Speed Problems

I have tested the MCOR and it is working fine as well. When testing the speed sensor while rotating the back wheel on the green wire I got readings from 3.5 volts to 7.5 volts which isn't within the range of 0-4.5v, but the testing manuals only say to replace the sensor if low readings are provided. Must be a speed sensor??
smaumau is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Slow speed problems. Electric Club Car
Cart Problems: Speed Sensor & Motor Stall Electric Club Car
07 Precedent Speed and Hill Problems Electric Club Car
Speed Controler Problems On Ezgo Test Post
95 low speed problems Gas EZGO


All times are GMT -5. The time now is 01:59 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.