lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-06-2008, 03:20 PM   #1
Not Yet Wild
 
MUDFREAK's Avatar
 
Join Date: Jul 2008
Posts: 51
Default battery ?

My charger keeps tripping and I was told to check the batteries. I did, and they are reading 8.3 except for two. The two are reading all different numbers. Please help.
Thanks, Mud Freak
MUDFREAK is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-06-2008, 04:28 PM   #2
Gone Wild
 
Join Date: Aug 2008
Location: Tucson, AZ
Posts: 979
Default Re: battery ?

did you check the batteries only with it sitting, or did you test voltage under load? Do a loaded reading, either by raising the back of the cart (so it doesn't drive off) and hook a meter to the batteries and test it as you press the go pedal. See what reading you get. You can test the entire bank first, and then test each battery individually until you find the bad one or two. You might find one that drops out under load. I had ONE at the end of my chain that was like that. It would read a little low, until under load then it dropped out almost completely. That's the bad thing about series battery packs, one bad batt in the chain can throw a monkey wrench in things.

I'm not entirely sure how this will affect your charger, but it's still a good idea to do the loaded tests to find the weak link. In my case, the charger seemed to be working fine even with the bad battery in the chain.
SP-Electronics is offline   Reply With Quote
Unread 09-06-2008, 04:51 PM   #3
Not Yet Wild
 
MUDFREAK's Avatar
 
Join Date: Jul 2008
Posts: 51
Default Re: battery ?

What are they supposed to read when you test them one by one?
MUDFREAK is offline   Reply With Quote
Unread 09-07-2008, 11:00 AM   #4
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: battery ?

The two batteries which are testing "all over the place" is not normal !
All test with the charger unplugged should give you a stable reading.
8.3 sounds reasonable for the other 6. I assume this is a 48Volt cart ?

Here is a link which will tell you everything you ever wanted to know about
testing charging and maintaning DEEP cycle batteries.

http://www.trojanbattery.com/Battery...e/Testing.aspx

Hope this helps and good luck !
GLEEMO is offline   Reply With Quote
Unread 09-07-2008, 07:55 PM   #5
Not Yet Wild
 
MUDFREAK's Avatar
 
Join Date: Jul 2008
Posts: 51
Default Re: battery ?

Thanks for the info.
MUD FREAK
MUDFREAK is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
battery help Electric Club Car
Another battery ?? sorry Electric Club Car
battery box Electric Yamaha
Battery Electric EZGO
What Battery? Gas EZGO


All times are GMT -5. The time now is 12:18 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.