lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-23-2013, 03:03 PM   #1
Not Yet Wild
Club Car
 
Join Date: Apr 2011
Location: dekalb il
Posts: 6
Thumbs up 04' club car precedent 48v

Hi my father has a 2004 club car 48v. While he was driving the cart during a round of golf the cart all of a sudden starting running about half speed. the batteries were about 6 years old and I replaced them with new batteries and new cables. It still starts out fine but immediately it drops back down to about half speed. I tried the to reset the OBC from the directions io found on this site but it still runs half speed. Can anyone please help me with getting my pops cart running again. Thank you so much for the help in advance i love this site!!!
membersbounce is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-23-2013, 06:07 PM   #2
Getting Wild
Club Car
 
Join Date: Aug 2011
Location: Western Michigan
Posts: 87
Default Re: 04' club car precedent 48v

Try out this thread, see if it helps

DS IQ or Precedent Speed Sensor Test

(You can also find it in the stickies up top)
Dhenryjr is offline   Reply With Quote
Unread 05-23-2013, 06:18 PM   #3
Gone Wild
 
CartTrader's Avatar
Club Car
 
Join Date: Aug 2008
Location: Ohio-In Summer, Central Florida-In winter
Posts: 887
Default Re: 04' club car precedent 48v

Sounds like the speed sensor went bad and it is going into limp mode!!


CartTrader
CartTrader is offline   Reply With Quote
Unread 05-24-2013, 10:02 AM   #4
Not Yet Wild
Club Car
 
Join Date: Apr 2011
Location: dekalb il
Posts: 6
Default Re: 04' club car precedent 48v

Thank you i will try that test this afternoon. It should be fairly easy to install a new one speed sensor correct? Any tricks to make it easy by chance? thank you again for the advise!!
membersbounce is offline   Reply With Quote
Reply

Tags
half speed, running slow, speed sensor
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
What is the value of my Club Car Precedent? Electric Club Car
Precedent Club Car Electric Club Car
Club Car Precedent Electric Club Car
05 Club Car Precedent Electric Club Car
Club Car Precedent from 12v to 8v? Electric Club Car


All times are GMT -5. The time now is 04:09 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.