lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-24-2013, 12:14 PM   #1
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Throttle issue?

99 Club Car series... The cart lurches and cuts out on power, when there is no load on the cart, there is no problem, with the tires up in the air cart runs just fine, but when you put a load on the cart it falters. Verified no motor issues, not transaxle related, test batteries and found one for a fact that was bad. Drove with volt meter on the cart and totally saw the battery dropping down to 3 volts or so, thought we had found our culprit, replaced the battery with a new one made sure pack was charged and there is no change. Owner said previous shop tested with their motor to rule it out, and also verified their controller good, only thing I can think of is a possible throttle issue or could the solenoid be dropping out?
cheapjeep2 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-24-2013, 09:05 PM   #2
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Throttle issue?

Ok I need some help...I have gone through everything on this cart and still cannot find the problem.. Here is what I have done..

1. New f/r switch, verified micro switches n the f/r
2. Found and replaced a bad battery, all batts are holding loads
3. Ohmed out the throttle at the controller, it is a 5k-0 throttle, ohms out perfect through entire range with no drop outs
4. Ohmed out the motor, zero shorts, a1-a2 continuity, s1-s2 continuity, no continuity anywhere else.
5. Jump solenoid main power terminals
6. Tested diode
7. Solenoid activation circuit is good, solenoid not dropping out, also jumped negative side of solenoid to -48v pack, no change.
8. no shorts or frays in any power cables.

Again it runs and then it is likes the controller stops putting out power and it cuts out goes cuts out goes, and it only does it under load, at this point I think it is the controller.

Help any ideas on what I am missing or is there something that you see that I have not tested?
cheapjeep2 is offline   Reply With Quote
Unread 05-24-2013, 09:10 PM   #3
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Throttle issue?

Sorry double post
cheapjeep2 is offline   Reply With Quote
Unread 05-25-2013, 09:55 PM   #4
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Throttle issue?

Bump. help....
cheapjeep2 is offline   Reply With Quote
Unread 05-27-2013, 05:41 PM   #5
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: Throttle issue?

I agree with you. I think the controller is the culprit. I've seen this before.
TahoeDawgZ71 is offline   Reply With Quote
Unread 05-27-2013, 05:55 PM   #6
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Throttle issue?

Quote:
Originally Posted by TahoeDawgZ71 View Post
I agree with you. I think the controller is the culprit. I've seen this before.
Thanks Dave
cheapjeep2 is offline   Reply With Quote
Unread 06-04-2013, 09:53 PM   #7
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Throttle issue? Fixed

WOW, what a night mare... I found it after an totally exhaustive search that involved two controllers a new forward and reverse switch and much, much more...

Even started a different thread about the AllTrax... My frustrations are growing - Alltrax Solid red light

Take a look at the picture... The owners son put in a different key switch used Wood screws, the power cables on both key switch lugs were loose, and that is why it would never have a problem when testing in a standing state and it would only act up while driving, the vibrations would shake the connections, and this is also why I could never find the problem cause I did have all the right voltages in every single test I did... ugh, what a nightmare.
Attached Images
File Type: jpg photo.jpg (255.3 KB, 0 views)
cheapjeep2 is offline   Reply With Quote
Unread 06-04-2013, 10:21 PM   #8
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: Throttle issue?

Wow..... Been there buddy. Don't feel alone. I've had stuff haunt me so many times and it almost always ends up being something like this.
TahoeDawgZ71 is offline   Reply With Quote
Unread 06-05-2013, 06:36 AM   #9
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Throttle issue?

. . . owner's son not very mechanically/electrically inclined . . .
Stevegrmich is offline   Reply With Quote
Unread 06-05-2013, 12:37 PM   #10
Getting Wild
 
Join Date: May 2013
Posts: 148
Default Re: Throttle issue?

Been there too. Worked on cars for better than 30yr. Worked on them before they had computers all way through port an direct injection systems. Seen a lot of gremlins (not talking about American Motors lol) but electrical problems can make you pull your hair out.
anix is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
yamaha g2 bogs at half throttle through full throttle Gas Yamaha
full throttle issue Electric Club Car
Junk speed controller or solenoid/resistors issue? no "0 speed" instant ~1/2 throttle Columbia ParCar
1989 par car throttle issue Gas Columbia ParCar
EZGo Marathon throttle issue Electric EZGO


All times are GMT -5. The time now is 09:01 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.