lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-07-2013, 05:28 AM   #11
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 96 club car wont charge

Quote:
Originally Posted by shempferd View Post
ok. Charger is working. Key was wired wrong. Hot was on the wrong terminal. Who knows why??

Now, the problem still remains. Wont charge. Still have 46 volts. We put a negative directly to the controller to bypass computer which also had no effect.

My neighbor lent me his maintenance and service manual for 95 and 96 cc's.

By jumping the relay in the charger, is that supposed to take the obc out of the loop? I did a continuity on the fuse on the charger receptacle and it checked ok.

. . . Yes . . .


Attachment 86273
Stevegrmich is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-08-2013, 08:43 AM   #12
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Re: 96 club car wont charge

My charger worked on a different cart.

Does anyone know where to find the fuse in the red wire going from the solenoid to the obc? Tough to get under there.

Thanks
shempferd is offline   Reply With Quote
Unread 06-08-2013, 08:44 AM   #13
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Re: 96 club car wont charge

Another question. If I took the obc out of the loop and my charger is ok, what else can it be? I checked all fuses except the one mentioned above.
shempferd is offline   Reply With Quote
Unread 06-08-2013, 09:37 AM   #14
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: 96 club car wont charge

It could be a bad obc
Speedchaser is offline   Reply With Quote
Unread 06-09-2013, 05:37 AM   #15
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 96 club car wont charge

Quote:
Originally Posted by shempferd View Post
Another question. If I took the obc out of the loop and my charger is ok, what else can it be? I checked all fuses except the one mentioned above.

. . . if you used the pic I posted to jumper the relay in the charger and the charger turned on and charged the battery pack, indications are that the OBC is not functioning . . . the OBC tells the charger to turn on and how much the pack needs for returning to full charge . . . assuming the OBC is connected properly to the system, you may be in need of a new OBC or you could remove OBC from system and purchase a new "smart" charger like ScottyB sells . . .
Stevegrmich is offline   Reply With Quote
Unread 06-09-2013, 10:44 AM   #16
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Re: 96 club car wont charge

My charger is a little different than the one in the picture. However, I did jump the two wires with the larger connectors together, which I believe are the correct one's to bypass the obc.

So I believe I have already bypassed the obc and it still doesn't work. I don't know if bypassing the obc would also bypass the fuse in the red wire going from the solenoid to the obc but it would make sense that it does.

It seems to me that bypassing the obc with a good charger should be all that is required. I've checked continuity from the charger to the batteries and the ground.

I guess I"m going to have to take her all apart and go one wire at a time. If anyone has any other suggestions, please let me know. Otherwise, I'll post my results when I find them.

Thanks for the help everyone.

Go Blackhawks!
shempferd is offline   Reply With Quote
Unread 06-10-2013, 06:53 AM   #17
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 96 club car wont charge

Quote:
Originally Posted by shempferd View Post
My charger is a little different than the one in the picture. However, I did jump the two wires with the larger connectors together, which I believe are the correct one's to bypass the obc.

So I believe I have already bypassed the obc and it still doesn't work. I don't know if bypassing the obc would also bypass the fuse in the red wire going from the solenoid to the obc but it would make sense that it does.

It seems to me that bypassing the obc with a good charger should be all that is required. I've checked continuity from the charger to the batteries and the ground.

I guess I"m going to have to take her all apart and go one wire at a time. If anyone has any other suggestions, please let me know. Otherwise, I'll post my results when I find them.

Thanks for the help everyone.

Go Blackhawks!
. . . did you check the fuse in the sense lead wire on the back of the cart's charger receptacle?
Stevegrmich is offline   Reply With Quote
Unread 06-21-2013, 10:38 PM   #18
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Re: 96 club car wont charge

Yes, I checked it. Showed continuity. I plugged the charger in again today now that I have the body off and it took a few seconds but then I heard the "click" in the charger and the transformer humming. However, still no amperage. I get 53.5 volts when I check the red wire coming out of the receptacle into the battery pack. However, still no amps.

Does anyone know what the voltage should read while charging?
shempferd is offline   Reply With Quote
Unread 06-21-2013, 10:41 PM   #19
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,047
Default Re: 96 club car wont charge

wow same as my friends cart ... amp meter may be bad
it will rise to around 57v
link ---> charger amp meter
crash test dummy is offline   Reply With Quote
Unread 06-22-2013, 12:12 PM   #20
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Re: 96 club car wont charge

My ammeter worked when I plugged my charger into a different cart. I believe the charger is fine. What I cant figure out is why bypassing the obc isnt working. The diode is bad on the solenoid but I cant believe that has anything to do with it. I also cant find the fuse on the red wire going from the solenoid to the obc. I found some heat shrink on the yellow, brown and red wires going into the obc and am guessing those are the fuses. Theyre barely larger than the wires themselves. Almost looks like heat shrink around a splice connector. I cant check continuity because they all die into the obc with no terminal ends.
shempferd is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
95 club car charger wont charge Electric Club Car
95 club car wont charge after a boo boo. Electric Club Car
Club Car wont take charge Electric Club Car
club car wont charge Electric Club Car


All times are GMT -5. The time now is 02:59 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.