lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-05-2013, 09:15 PM   #1
Not Yet Wild
 
Join Date: Jan 2013
Posts: 42
Default Drive question

Hey guys not sure if you've seen my Alltrax post, if not short version. Jumpiness got progressively worse in a quick amount of time. Cart now shutters but doesn't move much. I finally got the alltrax cable and the programing doesn't matter. I guess it could still be a MCOR but I played around with this afternoon and I can get it to barely move. It's almost like the gearing is messed up in that it shutters constantly but gradually moves forward and will move backwards in reverse as well. Almost like the drive shaft is spinning in the drive some how but not totally spun out.

Anyway to check the rear end? Does my thoughts sound like I'm on the right path. Sure doesn't seem like a mcor issue and now but it could have started there.
hawgsalot is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-06-2013, 12:34 AM   #2
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,861
Default Re: Drive question

Quote:
Originally Posted by hawgsalot View Post
Hey guys not sure if you've seen my Alltrax post, if not short version. Jumpiness got progressively worse in a quick amount of time. Cart now shutters but doesn't move much. I finally got the alltrax cable and the programing doesn't matter. I guess it could still be a MCOR but I played around with this afternoon and I can get it to barely move. It's almost like the gearing is messed up in that it shutters constantly but gradually moves forward and will move backwards in reverse as well. Almost like the drive shaft is spinning in the drive some how but not totally spun out.

Anyway to check the rear end? Does my thoughts sound like I'm on the right path. Sure doesn't seem like a mcor issue and now but it could have started there.
Shuttering is a sign of weak batteries. How old are your batts?
jakesnake27 is online now   Reply With Quote
Unread 06-06-2013, 04:03 AM   #3
Not Yet Wild
 
Hornsta's Avatar
Yamaha
 
Join Date: Dec 2012
Location: Torquay Australia
Posts: 69
Default Re: Drive question

I feel your woes hawgsalot, but as the prob only started after your alltrax install I would try some more programming, in the end I went back to default setting and headed of to golf, after 3 holes the shudder starts stopped and have not returned, I played 18 holes again yesterday and no prob but def. not as fast top speed as when I first installed, so I'm working on fixing that. Good luck and yes I fitted new Mcor to no avail, so try default and try changing throttle curve settings only.
Hornsta is offline   Reply With Quote
Unread 06-06-2013, 09:41 AM   #4
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: Drive question

Check your bats with a volt meter and load test them.
Speedchaser is offline   Reply With Quote
Unread 06-06-2013, 09:52 AM   #5
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,042
Default Re: Drive question

I agree ....... this complaint says batteries all over it.... and a jumpy throttle of course.
scottyb is online now   Reply With Quote
Unread 06-07-2013, 08:34 PM   #6
Not Yet Wild
 
Join Date: Jan 2013
Posts: 42
Default Re: Drive question

Batts are a year and a half old and read 53 volts under full power.
hawgsalot is offline   Reply With Quote
Unread 06-07-2013, 08:45 PM   #7
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,861
Default Re: Drive question

Quote:
Originally Posted by hawgsalot View Post
Batts are a year and a half old and read 53 volts under full power.
Hmmm, beats me.
Somebody else should chime in shortly...
jakesnake27 is online now   Reply With Quote
Unread 06-07-2013, 08:52 PM   #8
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,019
Default Re: Drive question

jack up the rear and see if it still shudders with no load on wheels .. just a short try , then try reverse ... again a short test ... if wheels spin without any shuddering.. then i'd check the motor coupling
Attached Images
File Type: jpg D390.jpg (46.8 KB, 0 views)
crash test dummy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
New Drive Belt question Gas Yamaha
G2 Drive clutch question Gas Yamaha
Drive Belt Question Gas EZGO
Drive clutch question? Gas EZGO
drive clutch question Gas EZGO


All times are GMT -5. The time now is 10:57 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.