lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-25-2013, 08:50 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jun 2013
Location: erie pa
Posts: 30
Default something poped when motor under strain no power

97 club car 48 volt regen was putting strain on motor something went bang the buzzer went off loss of power ,checked motor its ok drivetrain is ok I'm lost now the reverse buzzer works
stru-crew is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-26-2013, 05:44 PM   #2
Not Yet Wild
Club Car
 
Join Date: Jun 2013
Location: erie pa
Posts: 30
Default no power motor

I'm reposting this, I was backing over a small chunk of cement to put away in a tight spot ,the back wheels spun out very little then sounded like a metal snap ,then lost power,no back up buzzer, ok I checked the axles,batteries are full charged,solenoid is good it clicks,and reads 000 on meter when on and pedal down how do you check the other solenoid? I think motor is ok it hums for 5 seconds then stops with pedal down ,how do you test?
stru-crew is offline   Reply With Quote
Unread 06-26-2013, 06:12 PM   #3
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,008
Default Re: something poped when motor under strain no power

I had a battery with an internal short do this to me one time. Check the battery pack voltage while resting then hit the pedal and load the pack while checking them. Mine would drop to zero when loaded. The sound the battery made was loud. I thought it was a controller problem but I eventually found the issue.
TahoeDawgZ71 is online now   Reply With Quote
Unread 06-26-2013, 06:42 PM   #4
Not Yet Wild
Club Car
 
Join Date: Jun 2013
Location: erie pa
Posts: 30
Default Re: something poped when motor under strain no power

I checked each battery , all 8 volt with forward ,key on pedal down they never moved from one end to another its 48.7 off batteries, how do you test other solenoid?with the pedal down something is spinning in the end of motor
stru-crew is offline   Reply With Quote
Unread 06-27-2013, 02:30 AM   #5
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: something poped when motor under strain no power

48.7 v = about 50% aka no bueno
sunoco is offline   Reply With Quote
Unread 06-27-2013, 07:36 AM   #6
Not Yet Wild
Club Car
 
Join Date: Jun 2013
Location: erie pa
Posts: 30
Default Re: something poped when motor under strain no power

48.7 on a 48 volt system is 100% isn't it
stru-crew is offline   Reply With Quote
Unread 06-27-2013, 07:43 AM   #7
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: something poped when motor under strain no power





No sir. What are the actual voltages of each battery?
sunoco is offline   Reply With Quote
Unread 06-27-2013, 08:09 AM   #8
Not Yet Wild
Club Car
 
Join Date: Jun 2013
Location: erie pa
Posts: 30
Default Re: something poped when motor under strain no power

Thank you but I think they are good ,see this happened at my camp it hasn't been charged in awhile now its home to be worked on ,left charger at camp ,it should still run at 50% shouldn't it .my gut tells me its the motor ,had motor out and hooked up pedal down it won't turn
stru-crew is offline   Reply With Quote
Unread 06-27-2013, 08:17 AM   #9
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: something poped when motor under strain no power

Quote:
Originally Posted by stru-crew View Post
had motor out and hooked up pedal down it won't turn
Quote:
Originally Posted by stru-crew View Post
checked motor its ok drivetrain is ok I'm lost now the reverse buzzer works
Does the solenoid click when you push the pedal?
sunoco is offline   Reply With Quote
Unread 06-27-2013, 08:24 AM   #10
Not Yet Wild
Club Car
 
Join Date: Jun 2013
Location: erie pa
Posts: 30
Default Re: something poped when motor under strain no power

Yes checked and the motor buzz's ,what is the other solenoid? How do you test it?the reverse buzzer works
stru-crew is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
motor power? Electric golf carts
no power to motor? Electric EZGO
97 CC low power, motor controller? Electric Club Car
no power to motor Electric Yamaha
87 Marathon with new motor down on power Gas EZGO


All times are GMT -5. The time now is 12:31 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.