lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-28-2013, 10:04 AM   #1
Not Yet Wild
Club Car
 
Join Date: Jun 2013
Location: Atlanta
Posts: 4
Default Accelerator Pedal Travel

2005 DS, 48V, Accelerator Pedal in up position is 5" from wall, does not engage until I press pedal with-in 2" of wall, 3" of pedal travel until cart begins to move. Is this normal or should pedal engage movement sooner. If so provide possible cause and solution.
billcar is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-28-2013, 11:48 AM   #2
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,893
Default Re: Accelerator Pedal Travel

It could be a worn out MCOR. You can look under the cart to see if there is any play in it...
jakesnake27 is online now   Reply With Quote
Unread 06-28-2013, 12:13 PM   #3
Not Yet Wild
 
Sae255975's Avatar
Club Car
 
Join Date: May 2013
Location: Madisonville, La
Posts: 37
Default Re: Accelerator Pedal Travel

I had a similar issue with my cc, ended up being the mcor. Keep in mind I am a newbie to this so just letting you know what my issue was
Sae255975 is offline   Reply With Quote
Unread 06-29-2013, 05:51 AM   #4
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Accelerator Pedal Travel

. . . 5" from wall to back of GO pedal is normal setup/measurement . . . look down thru floorboard where GO pedal and MCOR input shaft mate . . does MCOR shaft begin to rotate when GO pedal is depressed? If GO pedal travels with no response from MCOR input shaft, you may have wear at the mating surfaces . . . try putting a shim between the two surfaces (like a thin washer, etc) and see if that improves pedal response . . if it does, replace GO pedal and MCOR input shaft (about $30 total at CC dealer) . . .
Stevegrmich is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Accelerator Pedal seems odd Electric Club Car
No response at accelerator pedal Electric Club Car
accelerator pedal problems Electric Club Car
Pedal travel and PB-6 lever travel coming up short Electric Club Car
accelerator pedal Electric EZGO


All times are GMT -5. The time now is 10:02 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.