lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-03-2013, 11:01 PM   #1
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default 96 cc ds just stopped working

One step forward.....

I just finally figured out I had a bad obc after a lot of diagnosing. I bought a new charger from ScottyB and the pack is now fully charged.

The problem is, now the cart doesnt move. I took a lot of time cleaning all the electrical connections and testing everything.I ran through every test the manual had. When I press the pedal, the solenoid clicks. The only test that wasn't perfect was for the speed controller.

The first test removes the wire from a2 on the motor, key on, fwd, pedal down until solenoid engages. Check for full batt voltage across small activating posts on solenoid. I only got 47.5 instead of 51.5

Then you check for input voltage. Removed red from controller terminal 1 and test across it and B-. You should get full pack volts, I got 48.3. It states to check wires and connections and to replace defective parts. None found but still not full voltage.

Then you check for output voltage. Now you check volts on B+ and M-. Should get 48v, controller capacitor voltage. I only got 38v. That's a big difference.

Finally turn key on, fwd, and watch voltage as you press pedal. Fully depressed should give full pack voltage, which it did, 51.5. Pedal released, 49.5 v.

When I went back to Neutral, volts dropped back to 38.

The controller is kind of odd. It's a Curtis model 1204-411, not 410. It may have been replaced, I don't know. Curtis website doesn't even show it. It has 4 large lugs instead of 3 like the manual shows. The fourth lug is labeled A2 with the white wire going from the F/R switch to it and then continuing on to motor A2. Controller says 36-48 volts, 235 amps. I'm wondering if the reason I'm getting only 38v out of the capacitor is due to this odd controller. Does anyone out there have this controller?

All of this being said (typed), I'm still surprised she's not moving. Everything worked fine except for the charging circuit. I cut the ground wire going from the charging receptacle to the obc and ran it directly to pack negative to check my charger, which worked. I tried running the cart with this wire disconnected as well as spliced back to the obc with no effect.

I tested the motor and it ran.

I'm really at a loss. Any help would be appreciated. I really don't have a lot of confidence that replacing the controller will work.

Thanks for reading my novel
shempferd is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-04-2013, 06:50 AM   #2
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 96 cc ds just stopped working

. . . did you disconnect any other wires associated with the OBC?
Stevegrmich is offline   Reply With Quote
Unread 07-04-2013, 08:02 AM   #3
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Re: 96 cc ds just stopped working

Nope.
shempferd is offline   Reply With Quote
Unread 07-12-2013, 02:23 PM   #4
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Re: 96 cc ds just stopped working

Just for future reference, the speed controller I have looks like it's for a mult-step potentiometer vs the continuously variable one. The manual shows four lugs for this type. My serial number dates my car after the switch so I guess someone put in the wrong controller. I have no idea if it matters. There was still a direct connection on the white wire in question. It just also fed lug A2 on the controller which isnt supposed to be there in the first place.
shempferd is offline   Reply With Quote
Unread 07-13-2013, 05:32 AM   #5
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: 96 cc ds just stopped working

What model controller?
sunoco is offline   Reply With Quote
Unread 07-13-2013, 08:45 AM   #6
Not Yet Wild
Club Car
 
Join Date: Jun 2013
Location: Vero Beach, Fl
Posts: 11
Default Re: 96 cc ds just stopped working

Try running two wires from the B- on the controller to the negative on the battery. One wire direct, and the second THRU the OBC. There will also be a third small wire running from the B- to the solenoid. One my 97 CC in would not move without the wire going THRU the OBC and the second “jumper” cable around it to the negitive.
Jimigoe is offline   Reply With Quote
Unread 07-13-2013, 07:23 PM   #7
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Re: 96 cc ds just stopped working

Quote:
Originally Posted by sunoco View Post
What model controller?
Curtis model 1204-411
shempferd is offline   Reply With Quote
Unread 07-13-2013, 07:24 PM   #8
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Re: 96 cc ds just stopped working

I think it has to be a grounding problem. I still have the original black wire going through the obc. I'll try going direct like you mentioned. This is driving me nuts. The new/used controller didnt fix anything.
shempferd is offline   Reply With Quote
Unread 07-15-2013, 12:00 AM   #9
Getting Wild
 
Join Date: Apr 2013
Posts: 86
Default Re: 96 cc ds just stopped working

No luck.

I'm going to burn it!!
shempferd is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZ GO TXT stopped working Electric EZGO
stopped working Electric EZGO
TXT Stopped Working Electric EZGO
cart stopped working Electric EZGO
Tach stopped working Gas Club Car


All times are GMT -5. The time now is 09:28 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.