lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-05-2013, 05:30 PM   #11
Gone Wild
 
CartTrader's Avatar
Club Car
 
Join Date: Aug 2008
Location: Ohio-In Summer, Central Florida-In winter
Posts: 887
Default Re: 2003 "AQ" lighting problem

That looks like either a relay switch or turn signal flasher. I would say a relay switch to turn the lights on. Not sure why it started smoking unless you have a short to ground.

CartTrader
CartTrader is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-05-2013, 05:59 PM   #12
Not Yet Wild
Club Car
 
Join Date: Jul 2013
Location: Florida
Posts: 24
Default Re: 2003 "AQ" lighting problem

I believe that to be the case. Would the ground be the blue terminal connected the the frame in an earlier pic?Thanks
Florida Cracker is offline   Reply With Quote
Unread 07-05-2013, 06:02 PM   #13
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: 2003 "AQ" lighting problem

Yes. One of the black wires should go to the negative post of a battery. The one obviously goes to the lights. Not sure about the 3rd, do you have any other accessories installed?
sunoco is offline   Reply With Quote
Unread 07-05-2013, 06:04 PM   #14
Gone Wild
 
CartTrader's Avatar
Club Car
 
Join Date: Aug 2008
Location: Ohio-In Summer, Central Florida-In winter
Posts: 887
Default Re: 2003 "AQ" lighting problem

Quote:
Originally Posted by Florida Cracker View Post
I believe that to be the case. Would the ground be the blue terminal connected the the frame in an earlier pic?Thanks
When you say "connected to the frame" do you mean the ground terminal bar that is mounted to the bar in front? It should not be connected to the frame in ANY way! If it is somehow grounding to the frame that may be the problem!

CartTrader
CartTrader is offline   Reply With Quote
Unread 07-05-2013, 06:05 PM   #15
Not Yet Wild
Club Car
 
Join Date: Jul 2013
Location: Florida
Posts: 24
Default Re: 2003 "AQ" lighting problem

I have a "red" wire going to the battery. I can see no "black" . I find this odd.
Florida Cracker is offline   Reply With Quote
Unread 07-05-2013, 06:07 PM   #16
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: 2003 "AQ" lighting problem

Follow the two black wires from that bus bar and see where they go.

The bus bar should be mounted to the frame, not grounded to it. It just looks like a common ground. One of the. lack wires should go to a neg post, or to a reducer if you have one

You could have a stock 18-12 reducer. Check the inside of the frame on driver side behind the batteries for a rectangle box.
sunoco is offline   Reply With Quote
Unread 07-05-2013, 06:09 PM   #17
Not Yet Wild
Club Car
 
Join Date: Jul 2013
Location: Florida
Posts: 24
Default Re: 2003 "AQ" lighting problem

I stated it incorrectly.....the first pic I posted shows it correctly. Wish I knew more about wiring and electricity.
Florida Cracker is offline   Reply With Quote
Unread 07-05-2013, 06:23 PM   #18
Not Yet Wild
Club Car
 
Join Date: Jul 2013
Location: Florida
Posts: 24
Default Re: 2003 "AQ" lighting problem

Would this be it?
Attached Images
File Type: jpg DSC_0012.jpg (162.8 KB, 0 views)
Florida Cracker is offline   Reply With Quote
Unread 07-05-2013, 06:42 PM   #19
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: 2003 "AQ" lighting problem

Yes. The reducer could have gone out, those things suck. If its in the budget, contact scottyb at cartsunlimited.net for a legitimate reducer that draws off of the whole pack instead of 2 batteries.
sunoco is offline   Reply With Quote
Unread 07-05-2013, 06:53 PM   #20
Not Yet Wild
Club Car
 
Join Date: Jul 2013
Location: Florida
Posts: 24
Default Re: 2003 "AQ" lighting problem

thanks....I will research. I appreciate your help here. You ever want to know about fishing or boats..... Just ask.
Florida Cracker is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2009 "The Drive" clutch problem Gas Yamaha
Why "Carbon Fiber" "Wood grain" and Diamond Plated? Gas EZGO
2003 ezgo 5" lift stalling problem Lifted Golf Carts
Tomberlin E2 48SS Battery Charing Problem "!!" Tomberlin
1994 EZGO Problem "Slipping" Electric EZGO


All times are GMT -5. The time now is 07:05 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.