lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-16-2008, 01:19 PM   #11
Not Yet Wild
 
Join Date: Sep 2008
Posts: 7
Default Re: Only speed I have is slow!

Thanks for all the help

Motor test good, so I ordered a new Controler, 480amp
MSknifemaker is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-16-2008, 02:54 PM   #12
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Only speed I have is slow!

i,m sorry but i don,t think your controller is the problem........................
shadowman is offline   Reply With Quote
Unread 09-17-2008, 12:31 AM   #13
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: Only speed I have is slow!

Welcome to the forum MSknifemaker................
rusty is offline   Reply With Quote
Unread 09-17-2008, 06:14 PM   #14
Not Yet Wild
Club Car
 
Join Date: Sep 2008
Location: Statesboro
Posts: 6
Default Re: Only speed I have is slow!

I have a 2003 48v cart that is doing the same thing. I have replaced the controller, potentiometer, and checked voltage to all the motor post. I jacked up the rear wheels and with the rod still attached to the potentiometer, I turned the rod and the wheels turned at a faster (better) rate. The solenoid clicks. Does the solenoid have anything with the speed?
platypus1926 is offline   Reply With Quote
Unread 09-18-2008, 06:22 PM   #15
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Only speed I have is slow!

i,m sorry guys i just never seen a controller make a cart run slower than it should, i have worked on many C.C,s that were slow for one reason or another but have yet to have the controller be at fault........i,m very interested it what happens when you replace it please let me know cause this will be a 1st for me and i will be very surprised........i know your upgrading controllers when you do this so thats gonna be different i wish you were putting a stock one back in.........please post when finished...........................
shadowman is offline   Reply With Quote
Unread 09-18-2008, 10:18 PM   #16
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: Only speed I have is slow!

I.Q. controllers will make the car run 3 mph when there is certain error codes detected.
phasetim is offline   Reply With Quote
Unread 09-18-2008, 11:39 PM   #17
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Only speed I have is slow!

thanks P i have yet to rtun into anything like that in all the carts and makes i have worked on..................................
shadowman is offline   Reply With Quote
Unread 09-29-2008, 12:35 PM   #18
Not Yet Wild
 
Join Date: Sep 2008
Posts: 7
Default Re: Only speed I have is slow!

After all the mess, replacing batteries controler, potentiometer, the problem turned out to be slack in the pedal assembly Alaways check the simple things first.

Thanks for all the help.
MSknifemaker is offline   Reply With Quote
Unread 09-29-2008, 02:03 PM   #19
Gone Wild
 
Join Date: Aug 2008
Location: Tucson, AZ
Posts: 979
Default Re: Only speed I have is slow!

MSknifemaker, what did you end up doing with your old controller after putting a new one in? If you want to part with your original, let me know, I'm in need of a stock controller.

whoops, nvm, don't think your controller will work for mine.
SP-Electronics is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Melex 36 Volt Cart only goes at slow speed Melex
2000 PDS goes to slow speed Electric EZGO
slow speed forward Gas golf carts
1999 no slow speed Gas Club Car
Touchy Gas Pedal At Slow Speed Gas EZGO


All times are GMT -5. The time now is 06:47 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.