lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-15-2008, 07:20 PM   #1
Not Yet Wild
Club Car
 
Join Date: Sep 2008
Location: Walleye Territory
Posts: 4
Default My batteries have power, but nothing works.

Ok, I have a 1996 Club Car 48V. So far we have had no problems with the cart. I don't know if charging with the key on and the F-N-R swith in the F position matters, but we charged the cart in that condition. I took the charger off the next day and the batteries were basically drained and the resister on the solenoid was burned. I took the resistor off and replaced it, still nothing. Now when I plug the charger in, the charger does nothing. I checked voltage to the solenoid, there is power to it, and when I put the F-N-R switch in F or N the power is on the other side of the solenoid (although not much because the batteries are nearly drained). I have no power to anything, including the low power light and the head/taillights. If anyone has any information or I can supply more information to help figure this out I would really appreciate it.
BigDex is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-15-2008, 07:35 PM   #2
Gone Wild
 
buckmanmike's Avatar
 
Join Date: Oct 2007
Location: Snellville, Ga.
Posts: 1,062
Default Re: My batteries have power, but nothing works.

Key on could cause a battery drain if you have gauges,etc. Battery voltage probably too low for charger to "see" them. Charge batteries with 12v charger to bring voltage up and then use your cart charger. I've never heard of problems of charging cart as far as where the FNR switch is engaged.
buckmanmike is offline   Reply With Quote
Unread 09-15-2008, 07:36 PM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: My batteries have power, but nothing works.

1st take voltage readings from batteries if your total voltage is under 36 to 38 volts the charger won,t come on it has a low voltage sensor.........if your batteries are above 38 volts than replace your OBC it went bad..............also if you can to make sure try your charger on another cart and try another charger on your cart................if you still have the red battery dash light than its the original OBC and there were problems with it but start by taking voltage readings to make sure.........................
shadowman is offline   Reply With Quote
Unread 09-15-2008, 07:39 PM   #4
Not Yet Wild
Club Car
 
Join Date: Sep 2008
Location: Walleye Territory
Posts: 4
Default Re: My batteries have power, but nothing works.

Ok, thanks, I'll give it a shot then post my results...
BigDex is offline   Reply With Quote
Unread 09-15-2008, 07:40 PM   #5
Not Yet Wild
Club Car
 
Join Date: Sep 2008
Location: Walleye Territory
Posts: 4
Default Re: My batteries have power, but nothing works.

Sorry, I don't know the acronyms. What's an OBC?
BigDex is offline   Reply With Quote
Unread 09-15-2008, 08:24 PM   #6
Not Yet Wild
Club Car
 
Join Date: Sep 2008
Location: Walleye Territory
Posts: 4
Default Re: My batteries have power, but nothing works.

So far so good! I charged the batteries with a 12v. charger, then I plugged in the charger and it finally recognized the cart. So...I am hopeful that the cart charger keeps charging and it's gonna be alright. Thanks guys!!
BigDex is offline   Reply With Quote
Unread 09-15-2008, 08:47 PM   #7
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: My batteries have power, but nothing works.

Welcome to the forum BigDex...................
rusty is offline   Reply With Quote
Unread 09-15-2008, 09:34 PM   #8
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: My batteries have power, but nothing works.

ok if its charging than your OBC ( on board computer ) should be good.......let the charger run till it shuts off and than drive it and see how it runs...........if it runs ok than your done if not post what happens.........by the way check your cables make sure they are clean and tight and check the water level in batteries if needed add distilled water only......................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Everything worked this morning but nothing works now??? Electric Club Car
99 Ez go, works forward not in reverse Electric EZGO
golf cart finally works! Gas Club Car
Yamaha in the works Design Center


All times are GMT -5. The time now is 10:19 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.