lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-01-2013, 01:24 PM   #1
Not Yet Wild
 
Join Date: Aug 2013
Posts: 3
Default 1988 Five Clicks with no movement

Greetings everyone. I've got a 1988 Club 36V car. Was running fine. I replaced all batteries last year and battery cables as well. The car has been great until last week. It simply stopped moving altogether. I can hear and feel all 5 solenoids clicking as I cycle the accelerator pedal but absolutely NO movement. I haven't jacked it up yet and direct jumped any solenoids as I didn't want to fry anything. I've been reading through as many of the "Clicking" posts as I can find. I was thinking of just replacing all 5 solenoids to begin with as I'm sure it would be good for it, however locally I can get one in stock. So is there an easy way to tell if it currently is just one? Or is it even a solenoid (s) issue. Because all 5 are clicking I assumed that meant they worked but I've read on here that may not necessarily be so? Also parts place asked if the cart was a V-Glide but I have no way of telling that. Any help would be greatly appreciated! Thanks so much.
Also for reference all batteries have good gravity readings and good charge.
cwhill is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-01-2013, 05:30 PM   #2
Not Yet Wild
 
Join Date: Aug 2013
Posts: 3
Default Re: 1988 Five Clicks with no movement

Well after some more poking around and starting to take things apart it was pretty easy to identify the issue here.
Attached Images
File Type: jpg 20130801_170444.jpg (201.4 KB, 0 views)
cwhill is offline   Reply With Quote
Unread 08-01-2013, 06:02 PM   #3
ΜΟΛΩΝ ΛΑΒΕ
 
93yellowclubcar's Avatar
Club Car
 
Join Date: Nov 2012
Location: West Virginia
Posts: 4,094
Default Re: 1988 Five Clicks with no movement

Quote:
Originally Posted by cwhill View Post
Well after some more poking around and starting to take things apart it was pretty easy to identify the issue here.
That'll do it! Likely all 5 are just as bad and brittle from my experience. Best to replace em all

Also, welcome to BGW!!
93yellowclubcar is offline   Reply With Quote
Unread 08-01-2013, 06:04 PM   #4
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,910
Default Re: 1988 Five Clicks with no movement

Yep that'll do it!
Welcome to BGW
jakesnake27 is offline   Reply With Quote
Unread 08-22-2013, 04:16 PM   #5
Not Yet Wild
 
Join Date: Aug 2013
Posts: 3
Default Re: 1988 Five Clicks with no movement

Sadly I replaced only the broken solenoid and the cart still exhibits the exact same problem. I get the 5 clicks when pressing the pedal and nothing else. Would a bad solenoid still click? I figured because they were clicking they must be conducting power or is that a completely wrong assumption? I just ordered the others to do them all now but I'm hoping I don't replace all solenoids and then have the same clicking problem and no go...
cwhill is offline   Reply With Quote
Unread 08-22-2013, 10:33 PM   #6
ΜΟΛΩΝ ΛΑΒΕ
 
93yellowclubcar's Avatar
Club Car
 
Join Date: Nov 2012
Location: West Virginia
Posts: 4,094
Default Re: 1988 Five Clicks with no movement

A clicking solenoid is not always a good solenoid... The deceptive little buggers can make a nice crisp pop and still be bad. Darn things get so brittle from the heat, and on those carts from the hundreds of thousands of times they've opened and closed. I'll bet the 5 new ones will fix your problem.
93yellowclubcar is offline   Reply With Quote
Unread 08-22-2013, 11:44 PM   #7
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 9,836
Default Re: 1988 Five Clicks with no movement

I would replace all, but test the one to the far left in your picture. It is the main "master", check for voltage on the busbar side with the pedal down.
cgtech is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZ GO Electric Cart Clicks but NO movement Forward or Reverse!! Electric EZGO
EZ GO Electric Cart Clicks but NO movement Forward or Reverse!! Electric Club Car
selenoid clicks, no movement Electric EZGO
Pedal clicks but no movement Electric EZGO
96 CC 48V Solenoid clicks no movement - Newbie Electric Club Car


All times are GMT -5. The time now is 05:29 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.