lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-03-2013, 05:32 AM   #1
Not Yet Wild
 
Join Date: Aug 2013
Posts: 4
Smile Club Car speed issue

Hi All what a fantastic forum
I have just purchased an old club car Serial no A803 17919 if that helps the cart runs ok however if you intend to climb a hill you have to hit the accelerator pedal quite aggressively in order to get the cart up the incline eg if your driving down the fairway and approach a large hill you have to stop and hit the pedal hard then the cart will travel up no problem, perhaps its jumping to second straight away, is this a speed switch problem of a solenoid issue thanks Heaps Mick
Mickbuggy72 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-03-2013, 01:22 PM   #2
What the.....?
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 11,368
Default Re: Club Car speed issue

Welcome to BGW Mick!
But the serial number isn't right... Is it A8803, or A9803?

lockman1 is offline   Reply With Quote
Unread 08-03-2013, 04:49 PM   #3
Not Yet Wild
 
Join Date: Aug 2013
Posts: 4
Default Re: Club Car speed issue

Hi Don. Definatley A8103 I don't know if it makes a difference but I am in Australia perhaps they used different serial no for export cars
Mickbuggy72 is offline   Reply With Quote
Unread 08-03-2013, 06:41 PM   #4
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,883
Default Re: Club Car speed issue

Ok, so it's an 81. You left out the 1 in your first post! No worries
jakesnake27 is offline   Reply With Quote
Unread 08-04-2013, 05:57 AM   #5
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Club Car speed issue

. . . not familiar with 81 . . . does it have a VGlide? If so, open the side case of VGlide, slowly depress the GO Pedal (with cart keyswitch in off position) and see if wiper arm rotates fully to last contact position . . . if it does not, then you need to adjust linkage to make sure it does . . . my son's cart had same issue (84 cart) . . . adjusted his linkage and he no longer had to slam the GO Pedal to get cart up to top speed . . .
Stevegrmich is offline   Reply With Quote
Unread 08-04-2013, 10:16 AM   #6
What the.....?
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 11,368
Default Re: Club Car speed issue

Steve, a 1981 should have a 5 micro switch/solenoid/resistor drive system...
A bad solenoid maybe?
lockman1 is offline   Reply With Quote
Unread 08-06-2013, 05:35 AM   #7
Not Yet Wild
 
Join Date: Aug 2013
Posts: 4
Default Re: Club Car speed issue

Yep it's a 5 solenoid configuration that are all connected via an external coil I have obtained the original manual that seems helpful and describes how to test all circuits so everything going to plan I should have a better feel for what the problem is tomorrow , will let you know if I find the fault
Thanks for your replys
Mickbuggy72 is offline   Reply With Quote
Unread 08-08-2013, 06:01 PM   #8
Not Yet Wild
 
Join Date: Aug 2013
Posts: 4
Default Re: Club Car speed issue

Thanks for the folks it was the speed switches just needing a good clean and adjustment the cart runs smoothly through all speeds now
Cheers Mick
Mickbuggy72 is offline   Reply With Quote
Unread 08-09-2013, 06:32 AM   #9
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Club Car speed issue

Quote:
Originally Posted by Mickbuggy72 View Post
Thanks for the folks it was the speed switches just needing a good clean and adjustment the cart runs smoothly through all speeds now
Cheers Mick
. . . great when it's an easy fix . . .
Stevegrmich is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Speed issue Electric Club Car
93 Club Car low speed issue Gas Club Car
Junk speed controller or solenoid/resistors issue? no "0 speed" instant ~1/2 throttle Columbia ParCar
g8 speed issue Gas Yamaha
'00 Club Car - Possible speed controller issue? Electric Club Car


All times are GMT -5. The time now is 01:09 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.