lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-03-2013, 11:16 PM   #1
Gone Wild
 
firenfix's Avatar
E-Z-GO
 
Join Date: Aug 2013
Location: Daytona Beach, Florida
Posts: 173
Default 68' Club Car variable speed issue

Restored Club Car, however, seems like there is no slow speed? Any help appreciated. Mike
Attached Images
File Type: jpg 68 Club Car A.jpg (126.3 KB, 0 views)
File Type: jpg 68 Club Car.jpg (110.5 KB, 0 views)
File Type: jpg 68 Club Car C.jpg (121.6 KB, 0 views)
firenfix is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-03-2013, 11:34 PM   #2
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 2,679
Default Re: 68' Club Car variable speed issue

The resistor coils are your speed control. You must have a problem with the switching of the coils. Slow speed is when the coils are dropping much of the battery voltage.
Volt_Ampere is offline   Reply With Quote
Unread 08-03-2013, 11:34 PM   #3
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,862
Default Re: 68' Club Car variable speed issue

Wow, what a cool cart and welcome to the forum!
When was this thing restored? It should have been upgraded to a solid state system!
I would say that your low speed solenoids are stuck closed.
jakesnake27 is offline   Reply With Quote
Unread 08-03-2013, 11:39 PM   #4
Gone Wild
 
firenfix's Avatar
E-Z-GO
 
Join Date: Aug 2013
Location: Daytona Beach, Florida
Posts: 173
Default Re: 68' Club Car variable speed issue

Restored in the last year or so, and the electronics are original as far as I can tell.
I'm sure many parts have been repaired/restored, but I don't see much in the way of updates?
firenfix is offline   Reply With Quote
Unread 08-03-2013, 11:41 PM   #5
Gone Wild
 
firenfix's Avatar
E-Z-GO
 
Join Date: Aug 2013
Location: Daytona Beach, Florida
Posts: 173
Default Re: 68' Club Car variable speed issue

The resistor coils seem to be in good shape, perhaps I should clean all contact points?
firenfix is offline   Reply With Quote
Unread 08-03-2013, 11:44 PM   #6
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,862
Default Re: 68' Club Car variable speed issue

Everything looks so shiny, it almost looks as if they put in new resistor coils, but I guess they could be original...
To update, you would rip out the toaster oven speed control and install a controller (much more efficient).
Does the cart have a v-glide, and how many solenoids?
jakesnake27 is offline   Reply With Quote
Unread 08-03-2013, 11:51 PM   #7
Gone Wild
 
firenfix's Avatar
E-Z-GO
 
Join Date: Aug 2013
Location: Daytona Beach, Florida
Posts: 173
Default Re: 68' Club Car variable speed issue

Hmmm, they could be new OEM's. Not sure what a v-glide is? The cart has 4 solenoids and I have four new ones being shipped.
firenfix is offline   Reply With Quote
Unread 08-04-2013, 12:03 AM   #8
Gone Wild
 
firenfix's Avatar
E-Z-GO
 
Join Date: Aug 2013
Location: Daytona Beach, Florida
Posts: 173
Default Re: 68' Club Car variable speed issue

Thanks for the help, I will certainly be checking back in often.
firenfix is offline   Reply With Quote
Unread 08-04-2013, 12:13 AM   #9
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,862
Default Re: 68' Club Car variable speed issue

Quote:
Originally Posted by firenfix View Post
Hmmm, they could be new OEM's. Not sure what a v-glide is? The cart has 4 solenoids and I have four new ones being shipped.
A v-glide is a black pie shaped box that controls the speed. I would guess that a couple solenoids are stuck closed, or dirty contacts on the v-glide (if it has one).
jakesnake27 is offline   Reply With Quote
Unread 08-04-2013, 09:32 AM   #10
Gone Wild
 
firenfix's Avatar
E-Z-GO
 
Join Date: Aug 2013
Location: Daytona Beach, Florida
Posts: 173
Default Re: 68' Club Car variable speed issue

Thanks Jake, I don't see any pie shaped control box but I did take a picture of what I think is a similar unit? Anyway, I will put new solenoids on this week and currently have the forward-reverse switch out as it is sticking a bit.

Thanks, Mike
Attached Images
File Type: jpg Control Box.jpg (65.0 KB, 0 views)
firenfix is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car speed issue Electric Club Car
93 Club Car low speed issue Gas Club Car
U-Max G28A is slow and variable Gas Yamaha
'00 Club Car - Possible speed controller issue? Electric Club Car


All times are GMT -5. The time now is 10:13 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.