lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-08-2013, 09:44 PM   #1
Gone Wild
 
Join Date: Jun 2013
Posts: 155
Default Headlight and brake stopped working

Ok I was putting my batteries back in on my 94 club car DS. All seemed well since I took pictures of where all the fat battery cables need to go. The only cable I coulnt account for is this skinny cable that must of been the horn, front lights and maybe brake light since nothing worked until I connected that to battery. Well in my first attempt I connected it where I thought it should go but as soon as I pulled the light switch the lights flicked on very bright and then stopped working. The horn worked but very loud and distorted. Pulled cabble off right away. So I placed the little cable on the second battery next to the one that has the red wire going to the FR switch. The horn sounded normal, the running lights turn on normal but headlights and brake light do not work anymore. Did I blow a fuse? Did I burn them out by putting too much voltage on them. Are the headlight and brake light connected to same fuse? Tails work but only the running lights when switch is pulled. Don't notice brake flash when pressed.
Waverider969 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-09-2013, 10:37 AM   #2
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,883
Default Re: Headlight and brake stopped working

You probably blew the bulbs with too much voltage. What is your carts year, model, and voltage?
jakesnake27 is offline   Reply With Quote
Unread 08-09-2013, 10:44 AM   #3
Gone Wild
 
Join Date: Jun 2013
Posts: 155
Default Re: Headlight and brake stopped working

Quote:
Originally Posted by jakesnake27 View Post
You probably blew the bulbs with too much voltage. What is your carts year, model, and voltage?
Its a 1994 DS , 36V. Yeah I thought about blowing the lights but why is it the running light still works on the rear lights just not the brake. Is it cause of separate filaments inside?

Those headlights really can't handle more than 12v??

I was really hoping it was the fuse. Its kinda hard to get to the fuse box so I haven't had time to check, but if its lights blown I'm looking at $10 each to replace fronts and who knows for back.. Ugh.

I still can't figure out how to remove the back lights from the body since they use some plastic rivet style attachment.
Waverider969 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
96 cc ds just stopped working Electric Club Car
EZ GO TXT stopped working Electric EZGO
stopped working Electric EZGO
TXT Stopped Working Electric EZGO
Brake/stop lights have stopped working need some tips on fixing Electric EZGO


All times are GMT -5. The time now is 11:57 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.