lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-14-2013, 11:34 PM   #1
Not Yet Wild
 
Join Date: Jan 2012
Posts: 70
Default Cart driving me nuts!

I have a 99 club car 48 volt. It charges fully and after leaving for a week, it is dead. Last week I disconnected the ground, checked batteries today and they are fully charged. Onl acc is a light which is off. Another syptoms, which I will post seperate, is while driving it will go one speed then intermittently pick up to normal speed with a indicated dropp in charge capacity, it is almost like it is dropping a battery then it kicks back in???
biminibrad is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-15-2013, 03:18 PM   #2
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,889
Default Re: Cart driving me nuts!

Quote:
Originally Posted by biminibrad View Post
I have a 99 club car 48 volt. It charges fully and after leaving for a week, it is dead. Last week I disconnected the ground, checked batteries today and they are fully charged. Onl acc is a light which is off. Another syptoms, which I will post seperate, is while driving it will go one speed then intermittently pick up to normal speed with a indicated dropp in charge capacity, it is almost like it is dropping a battery then it kicks back in???
It seems like something is definitely draining your batts, as it didn't do it when you disconnected them. I would trace any and all wires big or small coming off the pack...
jakesnake27 is offline   Reply With Quote
Unread 08-15-2013, 03:35 PM   #3
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,582
Default Re: Cart driving me nuts!

If You have a voltage converter/reducer for that light, that is a likely suspect. Leave the battery cable connected but disconnect the voltage reducer.
Sergio is online now   Reply With Quote
Unread 08-15-2013, 03:40 PM   #4
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,889
Default Re: Cart driving me nuts!

Quote:
Originally Posted by Sergio View Post
If You have a voltage converter/reducer for that light, that is a likely suspect. Leave the battery cable connected but disconnect the voltage reducer.
Yep or I was just thinking, remove the switch for the light, wire the light straight to the reducer and use the switch to power on and off the reducer. Then the light and reducer will go on and off at the same time...
When the switch is off, the reducer will be off and not draining pack.
jakesnake27 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
wobble nuts (variance nuts) for 4x100 rim Lifted Golf Carts
driving me nuts Electric Yamaha
Top end stuttering.......driving me nuts! ( Short trip tho! ) Gas EZGO
Club Car Driving Me Nuts Gas Club Car
What do You Drive When You're Not Driving Your Cart? Electric Club Car


All times are GMT -5. The time now is 01:38 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.