lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-07-2013, 11:23 AM   #11
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 82 Club Car no forward

I guess.....I just don't see how a bad connection or mechanical switch "resets" after a period of time.....this cart is VERY rough, body wise, cables, swelled up 10 year old batteries....everything really...wife wont let me drop coin on a new one , BUT, I can sneek parts here and there on the credit card.....I think ill strip it down to frame and make sure that's ok before I decide what to do with it......and while it was clicking I would wiggle and move everything on the F/R switch to see if it kicked in but nothing changes...

EDIT: well I told the kids (the boy had 3 friends stay over) just to go ahead and ride it and yell at me when it starts clicking......all four of them have rode the hell out of it for about an hour or so .....including a steep little climb up to the rope swing......never once did it die or click and they ran it down so low it barely made it back to the garage......im at a loss as to what was going on with it......
Budule is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-07-2013, 04:22 PM   #12
Not Yet Wild
 
Join Date: Oct 2012
Posts: 55
Default Re: 82 Club Car no forward

Check, very closely, all the connections on the two or three batteries on the passenger side of the cart. They are the ones that work only in forward. Checking voltage does not tell the story. A battery can read 6 volts and still be bad. You need a battery load tester. I can pretty much guarantee you that one of the batteries on the passenger side is bad.
NoBullBarry is offline   Reply With Quote
Unread 09-07-2013, 05:26 PM   #13
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 82 Club Car no forward

I have / did a load test and they all dropped pretty equal I thought......and, I know I need batteries as the NEWEST one is stamped march 06........ but she looks pregnant so maybe I am getting new batteries after all..........
Budule is offline   Reply With Quote
Unread 09-09-2013, 08:59 AM   #14
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 82 Club Car no forward

Well, charged it and kids rode most of the day dogging it out.......then it started clicking again......a quick load test on the batteries show one dropping down like a dead cell/short in it......but not all the time.....must be something floating around in there or something.....I may just buy 1 battery for it .....if im gona buy 6, then im going all the way and rebuild it .....
Budule is offline   Reply With Quote
Unread 09-09-2013, 10:37 AM   #15
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,069
Default Re: 82 Club Car no forward

Try to find a used battery for it. Putting a new battery in an old pack is a waste of money. The new battery will be damaged in each recharge cycle until it is soon equal to the rest of the pack.
scottyb is offline   Reply With Quote
Unread 09-09-2013, 12:02 PM   #16
Gone Wild
 
simple man's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Bunnell, Florida
Posts: 2,408
Default Re: 82 Club Car no forward

Quote:
Originally Posted by Budule View Post
Well, charged it and kids rode most of the day dogging it out.......then it started clicking again......a quick load test on the batteries show one dropping down like a dead cell/short in it......but not all the time.....must be something floating around in there or something.....I may just buy 1 battery for it .....if im gona buy 6, then im going all the way and rebuild it .....
I had a battery that would make and break a connection inside. Jarring it would get it back to working again. You're not the only one this has happened to! I'd try your local salvage yards for a used battery. A lot of times a whole set gets turned in and only one is bad. Golf cart shops are another place to try. Like "scottyb" said, buying 1 new battery would be a waste!
simple man is offline   Reply With Quote
Unread 09-09-2013, 01:53 PM   #17
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 82 Club Car no forward

Well went to autozone (took my load tester) and went in the back with the guy and when I put a load test on his oldest one (2012) it dropped a little (but not far from the rest of mine) I ank his if he had a 6volt charger (he didn't) but said I could have if for $70.00........so I took it.....just needs to get me to winter anyway......
Budule is offline   Reply With Quote
Unread 09-09-2013, 05:55 PM   #18
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 82 Club Car no forward

Well, never mind ....FIRE!!!!!.....put the new battery in and test drove and I noticed the vglide felt "rough" and was sticking somewhat....so, I take it off and switch around all the copper things by putting the rough top ones down at the botton and sanded it down abit....smooth as silk....put it back on and nothing.....noticed the wire from the vglide micro switch to the F/R switch had broke off at the F/R switch....so I went to loosen the bolt and it didn't move much so I went to get a different wrench and when I got back (only a few steps)....SMOKE!!!.......then FIRE!!!! ....started takeing cables off as fast as possible but to late......melted all cables and melted the lug right out of the new bettery....1 inch hole in top of it.....so, im done now I guess.....on to the rebuild.....maybe
Budule is offline   Reply With Quote
Unread 09-09-2013, 07:17 PM   #19
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,883
Default Re: 82 Club Car no forward

Yikes!

Now is the perfect time for a 48v solid state upgrade from this guy:
http://cartsunlimited.net/Custom_Options.html

No more screwing around with 30 year old parts and technology!
I have never done one of these upgrades, but I have never heard a bad thing about them...
jakesnake27 is offline   Reply With Quote
Unread 09-09-2013, 09:59 PM   #20
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 82 Club Car no forward

yeah, the fire freaked me out somewhat as I have never seen cables melt like that....and the battery melting the lead post right out (just before it burst into flames) was also a new one for me.......it looks like when I was trying to loosen the bolt on the F/R switch to reattach the micro switch wire I move the cable just enough to weld it to the other one......good times right there.....
Budule is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car will not go forward Electric Club Car
03 club car iq no go in forward Electric Club Car
95 club car won't go forward Electric Club Car
04 IQ club car no forward??? Electric Club Car
85 club car no forward only reverse Electric Club Car


All times are GMT -5. The time now is 03:32 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.