lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-02-2013, 06:44 PM   #1
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default 82 Club Car no forward

Well, the kids were riding the golf cart and they yelled at me that is was dead and "clicking"........it goes fine in reverse but just clickes in forward, not one single click but a constant click or grinding noise.......this model has only one solenoid and the coils in the back......
Budule is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-03-2013, 10:31 AM   #2
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 82 Club Car no forward

I went and checked it a little closer this morning and it seams to be that solenoid that is clicking or grinding......but works fine in reverse......I thought those were either on or off and didn't control the forward or reverse.....am I missing something?
Budule is offline   Reply With Quote
Unread 09-03-2013, 11:03 AM   #3
Gone Wild
 
Storm S's Avatar
Club Car
 
Join Date: Aug 2013
Location: PBG, Florida
Posts: 247
Default Re: 82 Club Car no forward

Check your micro switches on the FR switch.
Storm S is offline   Reply With Quote
Unread 09-03-2013, 11:06 AM   #4
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,081
Default Re: 82 Club Car no forward

grinding? could that be rapid fire clicking? Sounds like low battery power possibly. reverse only requires 18v. Check the pack voltage if it's okay , check the F&R switch ? let us know what you find....
scottyb is online now   Reply With Quote
Unread 09-03-2013, 11:19 AM   #5
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 82 Club Car no forward

well upon FURTHER inspection I found the main wires on the solenoid loose.....one VERY loose.....but tightening them didn't help, still rapid fire click or grinding.....and can feel that when I hold the solenoid.....maybe it was arcing inside .....battery pack had 37 volts.....which is amazing to me as ive had this cart over 4 years and the guy told me the batteries were 6 years old and junk when I bought it.....
Budule is offline   Reply With Quote
Unread 09-06-2013, 09:31 AM   #6
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 82 Club Car no forward

Got the new solenoid and just put it on........new sound (some kind of demonic groan instead of rapid fire clicking) still , no forward but reverse is fine.....one cable looks pretty corroded but its always looked bad under there.....im going to take out all batteries and brush the cables and stuff (a little water in there might not hurt as "I see lead, people") wifey wont let me get a new cart right now unless I get rid of the Rhino.....which im thinking about....
Budule is offline   Reply With Quote
Unread 09-06-2013, 09:57 AM   #7
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,081
Default Re: 82 Club Car no forward

I'll bet this is a battery problem. Put a meter on the pack and try to go, what does the meter drop to.
scottyb is online now   Reply With Quote
Unread 09-06-2013, 11:54 AM   #8
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 82 Club Car no forward

OK, sprayed battery cleaner everywhere and rinsed .....one cable had a pretty crodded end on it.....almost all cells low and SEVERAL dry on top..........was wiggling around on cables and the bottom one on the vglide (bottom stud with 2 wires ane to the toaster and one to the solenoid) was WAY loose, but had to take wires off and tighten the stud itself.....and one of those things fixed it.......YEA!......for about 30 feet.....then it just INSTANTLY stopped....almost "popped".......but still reverse good.....while fooling with it if you give it gas slow, it will click in and start to almost, then it pops out and rapid clicking.....something popped loud last time so im gona look for a black spot somewhere now......

EDIT: check voltage and the pack and it was 37 something ....each battery was 6.2 or so and on a load tester when you put a load they drop a little towards "weak" but none peg out like a bad cell or anything.........but little it sit a while caused it to go a few feet before stoping to click.....when I check voltage and stepping on the gas it drops from 37 down to 33 or so as its moving but quickly starts clicking and shoots down to around 9 volts or so....


Double Edit: Went out after letting it sit a while and it goes like crazy.....went up and down the road and up the driveway.....now , wth?......what on a hard wired cart could reset after resting for a while?......

Last edited by Budule; 09-06-2013 at 02:02 PM.. Reason: even moro info
Budule is offline   Reply With Quote
Unread 09-07-2013, 09:19 AM   #9
Gone Wild
 
Budule's Avatar
Club Car
 
Join Date: Sep 2010
Posts: 488
Default Re: 82 Club Car no forward

Anybody got anything?......I don't trust it now, and the kids are on me to ride it.....let it go till something melts I guess then fix it?......I may turn it into a winter project with the boy and just strip it down and rebuild everything, try one of those conversion kits.....
Budule is offline   Reply With Quote
Unread 09-07-2013, 09:46 AM   #10
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,081
Default Re: 82 Club Car no forward

Sounds like a bad connection now in the high amperage delivery system someplace ..... you just have to keep cleaning and tightening every single cable connection...... or it could be a bad F&R contact. Hard to say exactly from here.
scottyb is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car will not go forward Electric Club Car
03 club car iq no go in forward Electric Club Car
95 club car won't go forward Electric Club Car
04 IQ club car no forward??? Electric Club Car
85 club car no forward only reverse Electric Club Car


All times are GMT -5. The time now is 07:07 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.