lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-15-2013, 11:25 AM   #1
Not Yet Wild
 
Hogggman's Avatar
Club Car
 
Join Date: Aug 2013
Posts: 6
Default Help Please! Precedent took off

I'll try to keep this as short as possible but feel like the more descriptive I am the better you guys can help me hopefully. The whole issue started when I was checking the water in my dads 07 Precedent. I bumped a cable and it fell off it was pretty heavily corroded. I put a temporary end on it but ordered a set of 4 awg cables. Drove the cart into the shop changed the cables 1 at a time when changing the cables to the motor I accidently arced 1 to the control wire. Put all the cables on except the main ground because it wouldn't fit through the obc with the end still on it so I figured I would do it later. Checked it with the tires in the air and it worked fine. At the same time I wired in a small sound system. Its simply a small amp with an Ipod connector and 4 small speakers. Set the cart down and nothing and the resistor got really hot. Determined bad controller. Ordered an Alltrax DCX400IQ kit from Scotty B who has been really helpful. Installed the controller and it wouldn't go very fast. Talked to an Alltrax rep who was also extremely helpful and the controller wouldn't reach 100% throttle. Changed to a brand new MCOR did the same thing another bad controller. Got a replacement installed it and it did nothing. After many choice words and a few thrown tools I checked the MCor connections as the controller was recognizing 0 throttle position. Plugged in the old MCOr and used a screw driver to work it and it worked perfect. Decided to plug the other MCOR back in and now it worked perfect. Put everything back together drove the cart around for a while worked perfect. Pulled it back in the shop and changed that main ground cable and wired in a voltage reducer I had been running all the accessories off 1 battery. The accessories were disconnected when it was running perfect. Put everything back together the accessories were all working so it tapped the throttle to make sure it was ready to go and it did nothing tapped it again the cart took off hit the wall and did a burn out until the inline fuse blew. I disconnected the voltage reducer and just touched the cable to the batteries without the fuse and the controller turns on and blinks red 7 times. Overvoltage Im reluctant to do too much more diagnostic till I get another fuse but can someone help. I need to get this thing fixed its my dads and he uses it to get around to see the neighbors. He has ALS and cant walk very well.
Hogggman is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-15-2013, 03:15 PM   #2
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Help Please! Precedent took off

. . . wow . . . just wow . .
Stevegrmich is offline   Reply With Quote
Unread 09-15-2013, 10:51 PM   #3
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,866
Default Re: Help Please! Precedent took off

Quote:
Originally Posted by Stevegrmich View Post
. . . wow . . . just wow . .


This has to be the best thing I've seen on here ever!!!
It's amazing how good these spam bots are getting. Stringing together random sentences that they get off the website.
Scottyb, MCOR, Voltage reducer, Alltrax, etc, etc
jakesnake27 is offline   Reply With Quote
Unread 09-15-2013, 11:13 PM   #4
Not Yet Wild
 
Hogggman's Avatar
Club Car
 
Join Date: Aug 2013
Posts: 6
Default Re: Help Please! Precedent took off

I assure you I am not a bot. I am very real and genuinely need help. I am at my wits end with this thing and am desperate to get it fixed. I guess it sounds tough to believe and I wish I was making it up but I'm not.
Hogggman is offline   Reply With Quote
Unread 09-15-2013, 11:51 PM   #5
Not Yet Wild
 
Hogggman's Avatar
Club Car
 
Join Date: Aug 2013
Posts: 6
Default Re: Help Please! Precedent took off

Just to prove myself heres a pic of the wall it hit you can see the burnout marks on the floor and it destroyed my shelf. A pic of the box with the first alltrax controller on its way back and a picture of the cart with my dad and my daughter. I have changed the seat covers since the pic.
Attached Images
File Type: jpg wall aftermath.jpg (186.4 KB, 0 views)
File Type: jpg Alltrax.jpg (200.1 KB, 0 views)
File Type: jpg Dad and Addison.jpg (210.8 KB, 0 views)
Hogggman is offline   Reply With Quote
Unread 09-16-2013, 08:49 AM   #6
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,866
Default Re: Help Please! Precedent took off

So what do you need help with?
jakesnake27 is offline   Reply With Quote
Unread 09-16-2013, 09:33 AM   #7
Not Yet Wild
 
Hogggman's Avatar
Club Car
 
Join Date: Aug 2013
Posts: 6
Default Re: Help Please! Precedent took off

Figuring out why it took off and why the controller is blinking 7 times which I think means over voltage. But it was fine before
Hogggman is offline   Reply With Quote
Unread 09-18-2013, 01:00 PM   #8
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,866
Default Re: Help Please! Precedent took off

Quote:
Originally Posted by Hogggman View Post
Figuring out why it took off and why the controller is blinking 7 times which I think means over voltage. But it was fine before
Ok, so let's start simple.
1.) Does the cart charge properly?
2.) Does the cart run in forward and reverse?
jakesnake27 is offline   Reply With Quote
Unread 09-19-2013, 12:27 AM   #9
Not Yet Wild
 
Hogggman's Avatar
Club Car
 
Join Date: Aug 2013
Posts: 6
Default Re: Help Please! Precedent took off

Haven't tried charging yet just got the fuse today I didn't want to connect the pack without protection for the controller. It did already blow once. I talked to alltrax today and while he was on the phone I connected the pack. As I was tightening it I hit the wrench on the plate the controller mounts too and it arched the batteries were pretty slobbery and so the problem might be power on the frame. I cleaned it with baking soda and water and let it air dry ill try it again tomorrow. With it jacked up I hit the gas and it did keep going but only maybe quarter throttle. But that was before I cleaned it. So we'll see.
Hogggman is offline   Reply With Quote
Unread 09-24-2013, 05:16 PM   #10
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Help Please! Precedent took off

Insulate your tools with electrical tape. This helps prevent arcs.
jjance is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Set A Precedent On Road Golf Carts!
BB kit for 07 precedent available Big Block Talk!
Precedent Gas Test Post
Precedent Electric Club Car


All times are GMT -5. The time now is 07:41 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.