lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-30-2013, 08:56 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2013
Location: Texas
Posts: 8
Default Took Body off, now won't go

Hey everyone, I'm doing an overhaul on my golf cart and I took the body parts off to paint them. I disconnected everything from the charger where it goes through the front of the back body. Then disconnected the main battery cable and then another red cable underneath the rear access panel.

I installed a lift kit/tires and did some frame repair over about a month. I never ran the cart or charged it. I finally finished painting and put the body back on, connected everything back to where it was (used colored electrical tape to match connections so I didn't mess it up). Charged the cart overnight and when I tried it in the morning it wouldn't go anywhere. It just made a click sound and nothing. It made the buzz sound in reverse. When I lifted the back so the tires could spin freely it maybe did a rotation and a half and then quit. It wouldn't spin at all in reverse.

Any ideas?! I'm at a complete loss.

I attached a pic to show my progress, but it's all worthless if I can't move!

Thanks!
Attached Images
File Type: jpg IMG_5610.jpg (141.7 KB, 0 views)
Jspang is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-01-2013, 02:57 PM   #2
DS Drivers Club Founder
 
CCFanatic's Avatar
Club Car
 
Join Date: Jul 2013
Location: Upstate NY
Posts: 3,408
Default Re: Took Body off, now won't go

I would check the wires that plug into the FR switch. Could have been easily pluged in the wrong port on the switch
CCFanatic is offline   Reply With Quote
Unread 10-01-2013, 07:42 PM   #3
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,975
Default Re: Took Body off, now won't go

It don't take much of an arc to blow the controller. Just my guess.
mrgolf is offline   Reply With Quote
Unread 10-01-2013, 08:07 PM   #4
Not Yet Wild
Club Car
 
Join Date: Jul 2013
Location: Texas
Posts: 8
Default Re: Took Body off, now won't go

Unbelievably a wire in the controller box (which I never touched) came unplugged. Fixed it right up! haha, amazing...

Thanks for the responses y'all.
Jspang is offline   Reply With Quote
Unread 10-01-2013, 08:49 PM   #5
DS Drivers Club Founder
 
CCFanatic's Avatar
Club Car
 
Join Date: Jul 2013
Location: Upstate NY
Posts: 3,408
Default Re: Took Body off, now won't go

CCFanatic is offline   Reply With Quote
Reply

Tags
club car ds 2003 iq
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
DS Body 100 Golf Carts and Parts
DE-40 body Harley Davidson
g2 body fit a g1? Gas Yamaha
green body or camo dipped body Electric Club Car


All times are GMT -5. The time now is 05:10 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.