lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-15-2013, 01:35 PM   #41
Gone Wild
 
Storm S's Avatar
Club Car
 
Join Date: Aug 2013
Location: PBG, Florida
Posts: 247
Default Re: Any chance this is NOT bad batteries?

Quote:
Originally Posted by crash test dummy View Post
anyway to barrow another meter to double check yours ?
do you live on a grave yard ? lol
I have two. I'll double check same routine tomorrow and see.
Storm S is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-15-2013, 01:50 PM   #42
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Any chance this is NOT bad batteries?

The only volt readings that are valid in your case are the one you took after you let the battery rest. The chemical reactions inside the battery need time to come back into equilibrium. Here is a link that will tell everything you need to know about batteries.
http://evbatterymonitoring.com/
jjance is offline   Reply With Quote
Unread 10-15-2013, 03:26 PM   #43
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,886
Default Re: Any chance this is NOT bad batteries?

Here is another good link about batts:
http://cartsunlimited.net/How_Batteries_Work.html
jakesnake27 is online now   Reply With Quote
Unread 10-15-2013, 09:42 PM   #44
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Any chance this is NOT bad batteries?

I declare it is NOT bad batteries.
jjance is offline   Reply With Quote
Unread 10-16-2013, 02:03 PM   #45
Gone Wild
 
Storm S's Avatar
Club Car
 
Join Date: Aug 2013
Location: PBG, Florida
Posts: 247
Default Re: Any chance this is NOT bad batteries?

Ummmmm..... Okay so I have not had a chance to drive the cart yet I will do that later tonight but after my "maintenance" last night of taking all my wires off and wire brushing everything and double checking all water which seemed fine but I put some more in anyway. The charger has been off for more then 12 hours and the resting voltage is 51.43 and that voltage was identical by both multi meters. I will take it for a drive tonight and take some readings with both meters and see if I some how regained my 14 mile batteries or if they drop fast under load.
Storm S is offline   Reply With Quote
Unread 10-16-2013, 02:20 PM   #46
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,035
Default Re: Any chance this is NOT bad batteries?

your 45v reading .. was that with cart moving or at end of ride parked ?
under load readings will be lower due to conditions .. ie hills vs flat ground
crash test dummy is online now   Reply With Quote
Unread 10-16-2013, 02:23 PM   #47
Gone Wild
 
Storm S's Avatar
Club Car
 
Join Date: Aug 2013
Location: PBG, Florida
Posts: 247
Default Re: Any chance this is NOT bad batteries?

Quote:
Originally Posted by crash test dummy View Post
your 45v reading .. was that with cart moving or at end of ride parked ?
under load readings will be lower due to conditions .. ie hills vs flat ground
Parked and key off. I am beginning to to think and hope some how this was dirt related. My wires did NOT have corrosion on them as I always check but the ends were not squeaky clean which is why I decided to wire wheel them to a shiny copper color. I will see what happens tonight. Your thoughts?
Storm S is offline   Reply With Quote
Unread 10-16-2013, 02:27 PM   #48
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,035
Default Re: Any chance this is NOT bad batteries?

possible ... if you are getting a lot of corrosion, use a battery spray coating
crash test dummy is online now   Reply With Quote
Unread 10-16-2013, 07:34 PM   #49
Gone Wild
 
Storm S's Avatar
Club Car
 
Join Date: Aug 2013
Location: PBG, Florida
Posts: 247
Default Re: Any chance this is NOT bad batteries?

Okay.... So... This is what we have today.......
Starting voltage after a full rest 51.4
After 1 mile 50.9
After 2.5 miles 50.4
After 4.6 miles 50.3
After 6.6 miles 47.6
After 45 minute rest 50.7
A Final 9.6 miles (and almost not making it home) 45.0

Is it possible for my batteries to be accepting a full voltage charge but not being able to maintain their amperage? Batteries are shot right?
Storm S is offline   Reply With Quote
Unread 10-16-2013, 07:50 PM   #50
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,035
Default Re: Any chance this is NOT bad batteries?

yes i would say batteries are not holding a good charge and are weak ...
time to replace them ... read up on new batteries
Attached Files
File Type: pdf Battery Guide.pdf (45.4 KB, 0 views)
crash test dummy is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
What's the chance of this happening? Electric EZGO
Chance to buy Melex Melex
Finally got a chance to get it dirty.. Lifted Golf Carts
Chance at a G1 Gas Yamaha
New member with a chance to buy question Gas EZGO


All times are GMT -5. The time now is 09:42 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.