lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-18-2013, 11:24 AM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2012
Location: Williston SC
Posts: 72
Default 94 club car ds running problem

I have a 94 club car ds and I am having a problem with it running. the battery pack is a 50 volts when I let it charge over night I know that's not fully charges but it is enough for the cart to be driven around. the problem I am having is the cart will not move in forward or reverse. when you push the pedal you can hear the mcor click under and it will rock in the direction you are heading but want move. i have cleaned all the ends to every wire and have homed out every important wire. need to know where to go from here.

also just to let know the solenoid dose not click at all anytime. that's my next move but any advise would help thanks.
cfstokes55 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-18-2013, 11:26 AM   #2
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,908
Default Re: 94 club car ds running problem

Are you sure its a 94, because neither the MCOR or 48v existed then...
If you post your serial number that will help see exactly what you have...
jakesnake27 is online now   Reply With Quote
Unread 10-18-2013, 01:10 PM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2012
Location: Williston SC
Posts: 72
Default Re: 94 club car ds running problem

sorry was thinking of another cart at the time I wrote this it is a 98 club car and the serial number has been painted over sorry cant take a pic of it.
cfstokes55 is offline   Reply With Quote
Unread 10-24-2013, 09:32 AM   #4
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2012
Location: Williston SC
Posts: 72
Default Re: 94 club car ds running problem

problem solved, I jumped the mcor under the cart with a paper clip and with the cart in the AIR I pushed the pedal and bam, she took off. hooked the mcor back up and nothing. so I ordered one installed it and been working for two days now. had me whooped for about three days I fig that if it would try to move then it wouldn't be an mcor problem, but obviously I was wrong. Just relaying the info I gathered.
cfstokes55 is offline   Reply With Quote
Unread 10-24-2013, 10:56 AM   #5
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,091
Default Re: 94 club car ds running problem

Thanks for updating the thread. This will help others who use the search engine when looking for help.
scottyb is offline   Reply With Quote
Unread 10-24-2013, 12:00 PM   #6
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,908
Default Re: 94 club car ds running problem

Yep I agree with Scotty, thanks for letting us know and glad you got it fixed!
jakesnake27 is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2005 club car running problem Gas Club Car
2005 club car running problem Gas Club Car
81 G1 gas running problem Gas Yamaha
running problem Gas Club Car
Club Car 48V intermittant running problem Electric Club Car


All times are GMT -5. The time now is 08:33 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.