lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-22-2013, 10:21 AM   #1
Not Yet Wild
 
Join Date: Nov 2010
Posts: 19
Default 07 Precedent jerking hard

Well this is a intermetant problem that has been going on but now the cart is dead.
07Cart (new batteries well 11months old) When i hit the pedal I hear the light click from under the pedal then normally I hear a louder click which I assume is the relay under the seat.
Then my cart will move, but now The louder click is just not happining, I can set there and press the pedal like 100 times and every once and a while I hear the relay click under the seat and it starts to move for only a second then that's it. It may take another 100 or so times to get it to move for just a second again.

Any help appreciated seems like none of the dealers in my area want to fool with club cars WTF
ninjafreek is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-22-2013, 12:24 PM   #2
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,881
Default Re: 07 Precedent jerking hard

The click under the seat is the solenoid, and it sounds like it bad...
jakesnake27 is offline   Reply With Quote
Unread 10-22-2013, 12:42 PM   #3
Not Yet Wild
 
Join Date: Nov 2010
Posts: 19
Default Re: 07 Precedent jerking hard

Is it the thing that looks like a solenoid has 2 larger terminals on top.
Didn't really examine it closley. But with the seat off I put my hand on it and when i felt it click that's when I can get some movement out of it.
I was also wandering about the pedal switch but I hear it click every time I press the pedal but I assume that doesn't really mean its working properly?
ninjafreek is offline   Reply With Quote
Unread 10-22-2013, 12:57 PM   #4
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,881
Default Re: 07 Precedent jerking hard

Yes that is the solenoid with the two posts...
Are there only 2 wires going to it? One of them should get power when you step on the go pedal. If there is no power, the MCOR is probably acting up
jakesnake27 is offline   Reply With Quote
Unread 10-22-2013, 01:00 PM   #5
Not Yet Wild
 
Join Date: Nov 2010
Posts: 19
Default Re: 07 Precedent jerking hard

Thanks Ill ck that tonight I noticed there seems to be some sort of fused link or something also down there it seems to be all it tact. And sometimes after pressing the pedal several times as I stated it may move just for a second. It's been going on for sometime but now it may be dead I played with it last night became totally frustrated and gave up. I didn't know where to start checking.
Thanks for the starting point.
ninjafreek is offline   Reply With Quote
Unread 10-22-2013, 03:23 PM   #6
Not Yet Wild
 
Join Date: Sep 2013
Posts: 18
Default

Had similar issues with my 2010 model and it was the MCOR. Put a MCOR 4 on it and solved the issue. Not sure the 2007 model is the same though. I'd check there if the solenoid is good
CCC Player is offline   Reply With Quote
Unread 10-22-2013, 03:42 PM   #7
Not Yet Wild
 
Join Date: Nov 2010
Posts: 19
Default Re: 07 Precedent jerking hard

Where is that located to bypass it and try to check it?
I have not been able to get a pic of what it looks like, Is that the actual switch on the pedal?
ninjafreek is offline   Reply With Quote
Unread 10-22-2013, 07:33 PM   #8
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 07 Precedent jerking hard

There are 4 wires on the solenoid. Put your meter across the two small wires. You should read 48V when you press the pedal. Across the two large wires you should read 48v and when you press the pedal it will drop to zero. This is when it is working correctly.
jjance is offline   Reply With Quote
Unread 10-23-2013, 09:47 AM   #9
Not Yet Wild
 
Join Date: Nov 2010
Posts: 19
Default Re: 07 Precedent jerking hard

Go Figure, I When I returned home yesterday afterwork I try the cart and it works fine I tried moving it several times and it worked every time. It was a long late date at work so I left it at that didn't do any testing. The day before it moved just a couple feet and I had to push the frickin thing inside the garage,I left it outside for an hour plus and tried it several times with no luck.

Yesterday solenoid clicked evrytime and worked fine.
It seems to be worse when just off the charger.
ninjafreek is offline   Reply With Quote
Unread 10-23-2013, 01:12 PM   #10
Not Yet Wild
 
Join Date: Sep 2013
Posts: 18
Default

Mine did the same thing....if it starts acting up again, I bet it's the MCOR.
CCC Player is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Precedent light kit - hard install? Electric Club Car
Hard Jerking on acceleration Electric Club Car
2010 precedent lights die and cart starts jerking?? Electric Club Car
08 club car precedent jumps hard when it starts moving Electric Club Car
Jerking hard taking off Electric Club Car


All times are GMT -5. The time now is 02:25 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.