lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-23-2013, 10:57 AM   #1
Not Yet Wild
 
Join Date: May 2013
Posts: 9
Default Random movement problem

Earlier this year I did an MCOR upgrade on my parents 2000 DS Regen 48V cart and everything has been running great until recently. Sometimes when you depress the accelerator it clicks and doesn't move. Other times no click at all and of course, no movement. Same in both forward and reverse. Just wondering where I should start checking things out. Batteries and battery connections are fine.
bjm323 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-23-2013, 11:41 AM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,079
Default Re: Random movement problem

Check the micro switches first. One on the F&R and another in the MCOR need to connect for solenoid activation and controller power up. Check your Regen Cart Diagram.
scottyb is online now   Reply With Quote
Unread 10-23-2013, 01:10 PM   #3
Not Yet Wild
 
Join Date: Sep 2013
Posts: 18
Default

Just had same issue with my precedent. If it is an MCOR 3, it is most likely your problem. Swapped to MCOR 4 and runs perfect. Having same issues u were. Hope this helps. The local CC dealer had boxes full of them that they've changed out lately when I picked my new part up.
CCC Player is offline   Reply With Quote
Unread 10-23-2013, 01:52 PM   #4
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,893
Default Re: Random movement problem

Yep, I would bet this is an MCOR problem...
jakesnake27 is offline   Reply With Quote
Unread 10-23-2013, 02:14 PM   #5
Not Yet Wild
 
Join Date: May 2013
Posts: 9
Default Re: Random movement problem

Thanks for the replies. I should have mentioned that this is a PDP. No limit switches for fwd/rev switch, just one big switch. It is an MCOR 3.

Anyone have a part # on the MCOR 4? I don't have a CC dealer nearby.
bjm323 is offline   Reply With Quote
Unread 10-23-2013, 06:56 PM   #6
Not Yet Wild
 
Join Date: Sep 2013
Posts: 18
Default

I think serial # starts with 139....don't quote me on that. Send me PM and I'll give u info. I'm sure Tahoedawg knows off the top of his head.
CCC Player is offline   Reply With Quote
Unread 10-27-2013, 06:48 AM   #7
Not Yet Wild
 
Join Date: May 2013
Posts: 9
Default Re: Random movement problem

Quote:
Originally Posted by bjm323 View Post
I should have mentioned that this is a PDP
Regen 2
bjm323 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Need help with random cable Gas Club Car
Random No Starting Gas EZGO
Random Pics Announcements


All times are GMT -5. The time now is 05:11 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.